summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-27 14:45:04 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-27 14:50:13 -0800
commitd77d2d0183c01f91ebbade3bae3adc673da99240 (patch)
tree2e099002c9142c9029fa73423c3a7c1586502c67 /dev-python/automat
parentdev-python/m2r-0.2.1: bump, add py38 and pypy3 (diff)
downloadgentoo-d77d2d0183c01f91ebbade3bae3adc673da99240.tar.gz
gentoo-d77d2d0183c01f91ebbade3bae3adc673da99240.tar.bz2
gentoo-d77d2d0183c01f91ebbade3bae3adc673da99240.zip
dev-python/automat-0.8.0: bump, add py38 and pypy3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/automat')
-rw-r--r--dev-python/automat/Manifest1
-rw-r--r--dev-python/automat/automat-0.8.0.ebuild64
-rw-r--r--dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch27
3 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/automat/Manifest b/dev-python/automat/Manifest
index af99aefb7a7e..a278fa8c8a96 100644
--- a/dev-python/automat/Manifest
+++ b/dev-python/automat/Manifest
@@ -1,3 +1,4 @@
DIST Automat-0.5.0.tar.gz 32599 BLAKE2B 951da8840c2334fe3cd86804b39beedaad0d344d66742e8bb72e2d2ace2029b037acac8ffccc5643fd37f81020a567374a25ed42f7bc386770a30956464f52eb SHA512 7b4fc64e1b3cc514e3513c4be7387309a9e0c6d59ef091131404642b517a324b4a0eb677bee99da038664bd6713f2d2078c621f056e98b35966caf324741eeeb
DIST Automat-0.6.0.tar.gz 31767 BLAKE2B 28baa9d6cc7497f9c0a4b7f4050b197d3dff871b91f5f3e29bdc47ace443af8de0fbeacf1657dc6565b3ab824365362a42204d6d89a8dfc82eaa6cd92d4e2308 SHA512 94f2fa06b0e0e1c0538bcf4bd9046ea40600a018bdd1da2d5bed479877807ad56e448c4f1d7ec87341f80013ae6c35b01201cbe3c4ecae1105419038ed43024d
DIST Automat-0.7.0.tar.gz 61461 BLAKE2B dd09ce090c7333ee17b701bde2c78e01dacf40cefee847061a2019bb27f0982091e7628737211421ada351937caf9c6734cb445ee6462ce84b381030b013bd05 SHA512 a6f307d312a3ceb721071b5212297c73d2306894b5fafd39265578041a2859bd6f041ac43a654bdda4175a70a4e90e0db1ee35cd43fa620cd5c594b5d1988a74
+DIST Automat-0.8.0.tar.gz 59687 BLAKE2B 56e4ec76564d321ca9a709c484077a4003eea2842160e226728aaaa4ec6ebc2486482f79cd919bef7bbec8baeee7a34ca2a11d48665bb36c79c5a45a3c97e992 SHA512 2dbd4e784f65b02a8c93fc5f15236df3649d667a9792f6cac929dbac5d971495bdab4825df0fcd6817b9a9f79b7a5d8cfbdf8e4d18605f0761546b31b3091ad7
diff --git a/dev-python/automat/automat-0.8.0.ebuild b/dev-python/automat/automat-0.8.0.ebuild
new file mode 100644
index 000000000000..075a0b131e2d
--- /dev/null
+++ b/dev-python/automat/automat-0.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="A${PN:1}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Self-service finite-state machines for the programmer on the go"
+HOMEPAGE="https://github.com/glyph/automat https://pypi.org/project/Automat/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-python/m2r[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/automat-0.8.0-no-setup-py-m2r-import.patch"
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ if use test ; then
+ # Remove since this is upstream benchmarking tests
+ rm -r benchmark || die "FAILED to remove benchmark tests"
+ fi
+
+ # avoid a setuptools_scm dependency
+ sed -r -i "s:use_scm_version=True:version='${PV}': ;
+ s:[\"']setuptools[_-]scm[\"'](,|)::" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc docs/examples/*.py
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo "For additional visualization functionality install these optional dependencies"
+ einfo " >=dev-python/twisted-16.1.1"
+ einfo " media-gfx/graphviz[python]"
+}
diff --git a/dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch b/dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch
new file mode 100644
index 000000000000..161b219626da
--- /dev/null
+++ b/dev-python/automat/files/automat-0.8.0-no-setup-py-m2r-import.patch
@@ -0,0 +1,27 @@
+diff --git a/setup.py b/setup.py
+index d0dec04..7a85a6e 100644
+--- a/setup.py
++++ b/setup.py
+@@ -4,14 +4,6 @@ Setup file for automat
+
+ from setuptools import setup, find_packages
+
+-try:
+- from m2r import parse_from_file
+- long_description = parse_from_file('README.md')
+-except(IOError, ImportError):
+- print("\n\n!!! m2r not found, long_description is bad, don't upload this to PyPI !!!\n\n")
+- import io
+- long_description = io.open('README.md', encoding="utf-8").read()
+-
+ setup(
+ name='Automat',
+ use_scm_version=True,
+@@ -19,7 +11,6 @@ setup(
+ description="""
+ Self-service finite-state machines for the programmer on the go.
+ """.strip(),
+- long_description=long_description,
+ packages=find_packages(exclude=[]),
+ package_dir={'automat': 'automat'},
+ setup_requires=[