summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-21 19:18:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-21 19:18:31 +0100
commit3a9561557c2dec0f517566cd5086e29138c0d7a6 (patch)
treeae4f03edc1bedd1d8f5ff6d6ce43ddbd290cd1b5 /dev-python/asyncstdlib
parentmedia-radio/flrig: add 1.4.8 (diff)
downloadgentoo-3a9561557c2dec0f517566cd5086e29138c0d7a6.tar.gz
gentoo-3a9561557c2dec0f517566cd5086e29138c0d7a6.tar.bz2
gentoo-3a9561557c2dec0f517566cd5086e29138c0d7a6.zip
dev-python/asyncstdlib: Bump to 3.10.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asyncstdlib')
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.10.6.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index a7c0efc58390..f93e2e29969e 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1 +1,2 @@
DIST asyncstdlib-3.10.5.gh.tar.gz 54697 BLAKE2B b8a99a83e97084c4e09ddac0402ca23a8d42921b72774c0658aa0b9a1aa0ac1329baae782f105a52a4b6d979d490d97814ea6eac0e7570a7ca27784a27fa5c4d SHA512 3dfa8d1e5e2ef02dbf52fe7094b68496066978cfa9839cad59222ace40e0871369b45d93c1caa87e0f029c328253f6d72d8377625a8ed182498280662fcb7545
+DIST asyncstdlib-3.10.6.gh.tar.gz 56335 BLAKE2B 15b33e90454c2b1f9ca8ddd9c71db74af1541e26af59c1a5a8b6240ec7b9e5db06f0455c778de39ff6cce1e87db41403fbc1b8965da0764f8215c4dd6bfa8e17 SHA512 e8b8b72f7d59593876f6701632d4b4839bf6110134b8dc62a33f665c52528a94f53ac6c43195520c2902e66f68b379cf7d9258e29fb25c69ae2fa98cfe4b10a6
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.10.6.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.10.6.ebuild
new file mode 100644
index 000000000000..3aae64aa0b23
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.10.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/
+"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest