summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-16 15:19:34 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-16 16:13:31 +0100
commit9ba9673048467a36b1a0baec21f14e26457989b3 (patch)
treed970599b1279adc4b0c45f4848ceab7ba9be5171 /dev-python/argh
parentnet-misc/nextcloud-client: drop 3.6.1-r1, 3.6.4-r3 (diff)
downloadgentoo-9ba9673048467a36b1a0baec21f14e26457989b3.tar.gz
gentoo-9ba9673048467a36b1a0baec21f14e26457989b3.tar.bz2
gentoo-9ba9673048467a36b1a0baec21f14e26457989b3.zip
dev-python/argh: Bump to 0.28.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.28.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index d6476d33119f..d2d07c988298 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1,3 +1,4 @@
DIST argh-0.26.2.tar.gz 32913 BLAKE2B 315dc36c4a98cb4a8fdab68a30ed3d4d87d1565717722ed496255d8b1b4e505277032217da4c5d750f210974890d8094c52f920044173ff2168adf7cb7f6a2bd SHA512 90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707
DIST argh-0.27.1.tar.gz 49106 BLAKE2B 48f21d920d97111656cb5b18c956c7fdda94ae242f92ebfb02c47b55d5ccc1b82b0ef8b94a721f97fb3638b15b38ce3293fbe46ab123ed9c968efdb2e881d8f3 SHA512 edddd35b2a90c6286818986945e9ea8484dd06bc263016d8c52b0e29475dbad610d673acc0918d0cf62657b1d965bb0d59e51af4c384ae0610f471c748a90999
DIST argh-0.27.2.tar.gz 49200 BLAKE2B 4599781854feb0aa1b5251f6361bcf4e5e4f96c391fd8be3e5a3397d2a6130ec9111f36ad87dd553345a0d9d6471d20ecca7cd7462d41012c8117d2a07f18290 SHA512 9bed6d5f4ea6407be675b4b5c015e0bda5015ef78289ba9c08503687dc33d91fcda9aabdb9a94b9e3dc11020edf873e51eb1ef9d7ee0831b4f0eb0e302b83b98
+DIST argh-0.28.1.tar.gz 62511 BLAKE2B fb06ad73c5d8e8508103007a2213285f52f4d245ade288504616d42847c982a27ca94f0850f87052737c17740de705a9f8557fcafbea6f656e30ca1ed99efffb SHA512 c5d4515f5ba94a60dbcc6fa81812c192b51539ceee349129028a3d736ba1b0eac23135b31fa6d350e9fff778250365848e6c2077553849aeebbb9b67be6774dc
diff --git a/dev-python/argh/argh-0.28.1.ebuild b/dev-python/argh/argh-0.28.1.ebuild
new file mode 100644
index 000000000000..a5678353c3de
--- /dev/null
+++ b/dev-python/argh/argh-0.28.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="
+ https://pythonhosted.org/argh/
+ https://github.com/neithere/argh/
+ https://pypi.org/project/argh/
+"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="LGPL-3"
+
+BDEPEND="
+ test? (
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest