summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-22 06:00:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-22 07:53:26 +0200
commitff8b36577c6aa368c321c0501f0669ec245eed09 (patch)
tree80fe13b3f9aca281186e82a03de2d1dd46eb6e49 /dev-python/antlr4-python3-runtime
parentdev-python/websocket-client: Bump to 1.5.2 (diff)
downloadgentoo-ff8b36577c6aa368c321c0501f0669ec245eed09.tar.gz
gentoo-ff8b36577c6aa368c321c0501f0669ec245eed09.tar.bz2
gentoo-ff8b36577c6aa368c321c0501f0669ec245eed09.zip
dev-python/antlr4-python3-runtime: Bump to 4.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/antlr4-python3-runtime')
-rw-r--r--dev-python/antlr4-python3-runtime/Manifest1
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/Manifest b/dev-python/antlr4-python3-runtime/Manifest
index c12e2d983bdb..d6986f79b86b 100644
--- a/dev-python/antlr4-python3-runtime/Manifest
+++ b/dev-python/antlr4-python3-runtime/Manifest
@@ -1 +1,2 @@
DIST antlr-4.12.0.gh.tar.gz 4408352 BLAKE2B 9a7ba9149c459e5b6a7eec750d1623f10be4aa119479d93dbf7f3955176013ac3e56d3a95399460ed5170cf2bf01fff586852a84d2cb86fe04e89846211e39cd SHA512 2217509e8766ceee7b9e5fdee3a9972b1f42fb442bdf3e3c0a8027f88bc49508386adb5ea8a02c982ef2176e2b5e60669746a387ec426682d7f43bca28aa4b6f
+DIST antlr4-4.13.0.gh.tar.gz 4317288 BLAKE2B 7971b12a3d3fe50f50b9888a4de9cb7fdc28140c95a29fe00538a48da3434ec1c38643e7a1eb19457e0363b7e57747f5597081af59f653f7108f26f6515d8f35 SHA512 947ecca28712aa4dd98d7b7e0753e91881e55642f7951ca65a576b94db87440767a1b93d08e82db69ad527ee28bf89f0b2f9c0aaa604a999a7e48c163764ee12
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild
new file mode 100644
index 000000000000..31dcc7c87016
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=antlr4-${PV}
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="
+ https://www.antlr.org/
+ https://github.com/antlr/antlr4/
+ https://pypi.org/project/antlr4-python3-runtime/
+"
+SRC_URI="
+ https://github.com/antlr/antlr4/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}