summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-11 07:34:20 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-11 08:34:50 +0200
commit7df927f6805f85e1e50fe7f2a5b08f4b7bf69774 (patch)
tree3da393c6b3349b29e3c36f6d2a14715d50d3edac /dev-python/aiohttp
parentdev-python/aiohttp: Remove use of which(1) (diff)
downloadgentoo-7df927f6805f85e1e50fe7f2a5b08f4b7bf69774.tar.gz
gentoo-7df927f6805f85e1e50fe7f2a5b08f4b7bf69774.tar.bz2
gentoo-7df927f6805f85e1e50fe7f2a5b08f4b7bf69774.zip
dev-python/aiohttp: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild25
1 files changed, 20 insertions, 5 deletions
diff --git a/dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild b/dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild
index 117c3f29afc4..e0d71889aa44 100644
--- a/dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.8.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1 multiprocessing
@@ -99,10 +99,25 @@ python_test() {
tests/test_client_session.py::test_client_session_timeout_zero
)
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- # C extensions are not used on PyPy3
- tests/test_http_parser.py::test_c_parser_loaded
- )
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # C extensions are not used on PyPy3
+ tests/test_http_parser.py::test_c_parser_loaded
+ )
+ ;;
+ python3.11)
+ EPYTEST_DESELECT+=(
+ # known problem with tests, not code itself
+ 'tests/test_client_functional.py::test_timeout_on_reading_headers[pyloop]'
+ 'tests/test_client_functional.py::test_timeout_on_conn_reading_headers[pyloop]'
+ 'tests/test_client_request.py::test_data_stream_exc_chain[pyloop]'
+ tests/test_test_utils.py::TestAioHTTPTestCase::test_example_with_loop
+ tests/test_test_utils.py::TestAioHTTPTestCase::test_example_without_explicit_loop
+ tests/test_test_utils.py::TestAioHTTPTestCase::test_inner_example_without_explicit_loop
+ )
+ ;;
+ esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock,xdist.plugin,pytest_forked