summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/IPC-Shareable
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/IPC-Shareable')
-rw-r--r--dev-perl/IPC-Shareable/IPC-Shareable-0.610.0-r1.ebuild17
-rw-r--r--dev-perl/IPC-Shareable/Manifest1
-rw-r--r--dev-perl/IPC-Shareable/files/fix_perl_5.10_compat.patch17
-rw-r--r--dev-perl/IPC-Shareable/metadata.xml10
4 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/IPC-Shareable/IPC-Shareable-0.610.0-r1.ebuild b/dev-perl/IPC-Shareable/IPC-Shareable-0.610.0-r1.ebuild
new file mode 100644
index 000000000000..18860ad0e16e
--- /dev/null
+++ b/dev-perl/IPC-Shareable/IPC-Shareable-0.610.0-r1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSOUTH
+MODULE_VERSION=0.61
+inherit perl-module
+
+DESCRIPTION="Share Perl variables between processes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+SRC_TEST=do
diff --git a/dev-perl/IPC-Shareable/Manifest b/dev-perl/IPC-Shareable/Manifest
new file mode 100644
index 000000000000..196b83f5899e
--- /dev/null
+++ b/dev-perl/IPC-Shareable/Manifest
@@ -0,0 +1 @@
+DIST IPC-Shareable-0.61.tar.gz 29730 SHA256 c2ffa5bbda076acd9fc1b7d9dab1ce6707f345c5a833431b5a8ee0f8744720c4 SHA512 cc55053bbdb73868bd40d4c3d83e0929107c84fe2ff07c82235e7617eb0a3c204d4569ddbd16468732cd9d3a0c4cac3672f1f1ca1178d975f4a69ed7b96b75e9 WHIRLPOOL 95bc3c1d7bed1493ccd99b39e3bd9f7cfe3fcab0d3d06c5b8f1cf260917aabf9d403cc10a70247d6a2c3b3e83bdd211bbd7a656c40b0a0d63a5cf2ff5120fc98
diff --git a/dev-perl/IPC-Shareable/files/fix_perl_5.10_compat.patch b/dev-perl/IPC-Shareable/files/fix_perl_5.10_compat.patch
new file mode 100644
index 000000000000..c788d58e03c5
--- /dev/null
+++ b/dev-perl/IPC-Shareable/files/fix_perl_5.10_compat.patch
@@ -0,0 +1,17 @@
+http://rt.cpan.org/Public/Bug/Display.html?id=41401
+http://bugs.debian.org/507657
+# Getting $# of an already-dereferenced-arrayref is a no-go in Perl 5.10
+Index: libipc-shareable-perl/lib/IPC/Shareable.pm
+===================================================================
+--- libipc-shareable-perl.orig/lib/IPC/Shareable.pm 2008-12-03 10:51:27.000000000 -0600
++++ libipc-shareable-perl/lib/IPC/Shareable.pm 2008-12-03 10:51:46.000000000 -0600
+@@ -452,7 +452,7 @@
+ my $n = shift;
+
+ $self->{_data} = _thaw($self->{_shm}) unless $self->{_lock};
+- $#{@{$self->{_data}}} = $n - 1;
++ $#{$self->{_data}} = $n - 1;
+ if ($self->{_lock} & LOCK_EX) {
+ $self->{_was_changed} = 1;
+ } else {
+
diff --git a/dev-perl/IPC-Shareable/metadata.xml b/dev-perl/IPC-Shareable/metadata.xml
new file mode 100644
index 000000000000..ab14d96293da
--- /dev/null
+++ b/dev-perl/IPC-Shareable/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">IPC-Shareable</remote-id>
+ <remote-id type="cpan-module">IPC::Shareable</remote-id>
+ <remote-id type="cpan-module">IPC::Shareable::SharedMem</remote-id>
+ </upstream>
+</pkgmetadata>