summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-14 06:14:07 +0000
committerSam James <sam@gentoo.org>2022-01-03 07:40:47 +0000
commitc127713269a116c187d54663e0523b9f79f11886 (patch)
tree74c0678b2062673165a06047996a4ef48716151c /dev-libs
parentnet-mail/mailutils: bump to 3.14 (diff)
downloadgentoo-c127713269a116c187d54663e0523b9f79f11886.tar.gz
gentoo-c127713269a116c187d54663e0523b9f79f11886.tar.bz2
gentoo-c127713269a116c187d54663e0523b9f79f11886.zip
dev-libs/pocl: use 'distro' option for built kernels
We can't know what CPU the user will run the built package on (think of binpkgs) so let's use the 'distro' option which builds for most common SIMD instructions and chooses the most appropriate kernel it built at runtime. Closes: https://bugs.gentoo.org/829128 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/pocl/pocl-1.8-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-libs/pocl/pocl-1.8-r1.ebuild b/dev-libs/pocl/pocl-1.8-r1.ebuild
index 6ee4d704b519..13e8dd263413 100644
--- a/dev-libs/pocl/pocl-1.8-r1.ebuild
+++ b/dev-libs/pocl/pocl-1.8-r1.ebuild
@@ -73,7 +73,7 @@ src_configure() {
-DENABLE_HSA=OFF
-DENABLE_ICD=ON
-DENABLE_POCL_BUILDING=ON
- -DKERNELLIB_HOST_CPU_VARIANTS=native
+ -DKERNELLIB_HOST_CPU_VARIANTS=distro
-DPOCL_ICD_ABSOLUTE_PATH=ON
-DSTATIC_LLVM=OFF
-DWITH_LLVM_CONFIG=$(get_llvm_prefix -d "${LLVM_MAX_SLOT}")/bin/llvm-config