summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-08 23:37:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-19 01:22:24 +0100
commitfe98d2ff58f9d48ecaa676e74b5669d5fa8d98eb (patch)
tree4ff650d18ce00808233f21f82618237fc2bc879a /dev-libs/libixion
parentapp-mobilephone/gammu: Fix HOMEPAGE (diff)
downloadgentoo-fe98d2ff58f9d48ecaa676e74b5669d5fa8d98eb.tar.gz
gentoo-fe98d2ff58f9d48ecaa676e74b5669d5fa8d98eb.tar.bz2
gentoo-fe98d2ff58f9d48ecaa676e74b5669d5fa8d98eb.zip
dev-libs/libixion: 0.13.0 version bump
Dropped keywords for testing. Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-libs/libixion')
-rw-r--r--dev-libs/libixion/Manifest1
-rw-r--r--dev-libs/libixion/libixion-0.13.0.ebuild54
-rw-r--r--dev-libs/libixion/libixion-9999.ebuild4
3 files changed, 57 insertions, 2 deletions
diff --git a/dev-libs/libixion/Manifest b/dev-libs/libixion/Manifest
index 8c2f52de82b4..57f5f3df2f09 100644
--- a/dev-libs/libixion/Manifest
+++ b/dev-libs/libixion/Manifest
@@ -1,2 +1,3 @@
DIST libixion-0.11.1.tar.xz 366660 SHA256 c9e9f52580d618fa969fc0293f55af21a9c74bfb802e655c6bf239202f95bede SHA512 e205a5cf532e0522291f5f2a52c2e2c0cdf8d2ed094e5553943650744359d67adf629229a6ffff3c8fa90b15dde7765fee14d4f147fe51a6cdf79b2855509858 WHIRLPOOL aff1350bd1e3a5fec3f0a0cd3f51a88c873bd28469884b48d3fc316782819465f7d193e019fc753474663326b27680c1d12ce3050e6a082a75073040147dfbd8
DIST libixion-0.12.2.tar.xz 407280 SHA256 8b44008836bb4e1a3dff4d3e40afec6c73037e3518e72cc85b5cc675fbc2daae SHA512 0a85120a08c79c73a252a997c8b3df461fe1f8ce8b2334aee0e50bfd887a440a220b44922edd18fbd402b1c8ea8be629e6181493bc618eda198f35159813ddcd WHIRLPOOL 3090887ffaa1222a3f15e4d5b96932d50392684ffaa4ea1022f14aeac7fc43972ed84fe6986c58360621e4ab1ad2ca5aa31694fbf081e8014de38b9ade1a060b
+DIST libixion-0.13.0.tar.xz 413756 SHA256 5ae360c52ba2d17c4abf5ae21fa947f75925459e085acef5972395f77333c7e5 SHA512 15784e947164d106e677c59ece53b3cd401d4f9433cc5331a35d3be8332ae4f20a469ca73b30b253433c86da4afde886dfb4ac23e46ed46376a7349e0276c3a0 WHIRLPOOL 702b8bc869273e9ccab4605426573ca514ad4ca7e898bc6f43cb442b4c55b5c129eddd524dc8a412b2fcadcb7501e6f5d70bd40b5f86525aa4c8690fa44962f2
diff --git a/dev-libs/libixion/libixion-0.13.0.ebuild b/dev-libs/libixion/libixion-0.13.0.ebuild
new file mode 100644
index 000000000000..1cf9c89f9768
--- /dev/null
+++ b/dev-libs/libixion/libixion-0.13.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/ixion/ixion.git"
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+inherit python-single-r1 ${GITECLASS}
+unset GITECLASS
+
+DESCRIPTION="General purpose formula parser & interpreter"
+HOMEPAGE="https://gitlab.com/ixion/ixion"
+[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/0.13" # based on SONAME of libixion.so
+# [[ ${PV} == 9999 ]] || \
+# KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="debug python static-libs +threads"
+
+RDEPEND="
+ dev-libs/boost:=
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/mdds-1.2.0:1=
+"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable python) \
+ $(use_enable static-libs static) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/dev-libs/libixion/libixion-9999.ebuild b/dev-libs/libixion/libixion-9999.ebuild
index cd31a4887aae..7fed246e3057 100644
--- a/dev-libs/libixion/libixion-9999.ebuild
+++ b/dev-libs/libixion/libixion-9999.ebuild
@@ -13,12 +13,12 @@ unset GITECLASS
DESCRIPTION="General purpose formula parser & interpreter"
HOMEPAGE="https://gitlab.com/ixion/ixion"
-[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/ixion/src/${P}.tar.xz"
+[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/ixion/src/${P}.tar.xz"
LICENSE="MIT"
SLOT="0/0.13" # based on SONAME of libixion.so
[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="debug python static-libs +threads"
RDEPEND="