summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-04 21:19:02 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-04 21:49:35 +0100
commitb9b3db2aac68698e485624e53884f52596828bd2 (patch)
treedcfa910db61a96c5b9487d1c752ba9b117cb096b /dev-lang
parentapp-office/gnumeric: Version bump to 1.12.56 (diff)
downloadgentoo-b9b3db2aac68698e485624e53884f52596828bd2.tar.gz
gentoo-b9b3db2aac68698e485624e53884f52596828bd2.tar.bz2
gentoo-b9b3db2aac68698e485624e53884f52596828bd2.zip
dev-lang/eisl: bump to 3.60
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/eisl/Manifest1
-rw-r--r--dev-lang/eisl/eisl-3.60.ebuild48
-rw-r--r--dev-lang/eisl/files/eisl-3.60-Makefile.patch32
3 files changed, 81 insertions, 0 deletions
diff --git a/dev-lang/eisl/Manifest b/dev-lang/eisl/Manifest
index 4c78e0da4315..176a579fa365 100644
--- a/dev-lang/eisl/Manifest
+++ b/dev-lang/eisl/Manifest
@@ -1 +1,2 @@
DIST eisl-3.50.tar.gz 2428194 BLAKE2B bab17dc6ab00f894cd4e9558a1bbc4bca9eb2770de46eb30d015e9e7542c774f2d55427bea05d5c5c6d910eec9a9de3d84568f9ec12043f20bbcdc542f0294ff SHA512 53d23a86a5b15ff04c268db348b5edb61eb0709cb1ef21e5b9ca7eda8954a0ab2b9dad345c3a9d80325cbfe35e879516b0d8d98609cf68dcad8898b5ce10c175
+DIST eisl-3.60.tar.gz 2429781 BLAKE2B 7a5752df5682444fb3a1381030e1c73a1859021d9d18a5c2f0afc257012ef12d169c952044202f6f591965cbee4caab269ee362d317d6f87d09077d1f217857d SHA512 400e2a6e8c3de9fe97a240adbab6ec61ccff69a1b407443b7c832b357a390d16cef1090494f314cd3d16278cca131695345b8c6e0fe51e658c45dd3bea20e4f6
diff --git a/dev-lang/eisl/eisl-3.60.ebuild b/dev-lang/eisl/eisl-3.60.ebuild
new file mode 100644
index 000000000000..866b41aa1866
--- /dev/null
+++ b/dev-lang/eisl/eisl-3.60.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
+HOMEPAGE="https://github.com/sasagawa888/eisl/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
+else
+ SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+RESTRICT="test" # Tests run cppcheck (and fail)
+
+DOCS=( README{,-ja}.md documents )
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-3.60-Makefile.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" clean edlis eisl
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe edlis eisl
+
+ # Compilation of ISLisp files on installation fails.
+ # Do not compile them and mimic "make install".
+ insinto "/usr/share/${PN}"
+ doins -r library
+ doins fast.h ffi.h
+
+ einstalldocs
+}
diff --git a/dev-lang/eisl/files/eisl-3.60-Makefile.patch b/dev-lang/eisl/files/eisl-3.60-Makefile.patch
new file mode 100644
index 000000000000..3c9c763fd608
--- /dev/null
+++ b/dev-lang/eisl/files/eisl-3.60-Makefile.patch
@@ -0,0 +1,32 @@
+--- a/makefile
++++ b/makefile
+@@ -39,7 +39,7 @@ else
+ endif
+ endif
+ endif
+-CFLAGS += $(INCS) -g -Wall -Wextra -D_FORTIFY_SOURCE=2 $(CURSES_CFLAGS) -U_XOPEN_SOURCE -Inana/src
++CFLAGS += $(INCS) -g $(CURSES_CFLAGS) -U_XOPEN_SOURCE -Inana/src
+ DFLAGS := --preview=all --de -w --O3 --release --betterC
+ SRC_CII := cii/src/except.c cii/src/fmt.c cii/src/str.c cii/src/text.c
+ SRC_D := dextension.d disl.d
+@@ -69,7 +69,7 @@ ifeq ($(DEBUG),1)
+ LDFLAGS += -fsanitize=undefined
+ endif
+ else
+- CFLAGS += -O3 -flto -DNDEBUG=1 -DWITHOUT_NANA=1
++ CFLAGS += -DNDEBUG=1 -DWITHOUT_NANA=1
+ SRC_CII += cii/src/mem.c
+ endif
+ OBJ_CII := $(SRC_CII:.c=.o)
+@@ -87,11 +87,8 @@ ifeq ($(shell uname -n),raspberrypi)
+ CFLAGS += -D__rpi__
+ endif
+ ifneq ($(DEBUG),1)
+- LDFLAGS += -flto
+ ifeq ($(shell uname),Darwin)
+ LDFLAGS += -Wl,-S,-x
+- else
+- LDFLAGS += -s
+ endif
+ endif
+ PREFIX := /usr/local