summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-04-17 19:23:38 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-04-17 21:31:10 -0400
commitde035788fb8ceddd4a7b3fd038537f2e530009f1 (patch)
tree4ac3937c5ac4b4642254f3122e948c043073bd57 /dev-lang/R
parentacct-user/consul: new user for vault (approved by zmedico) (diff)
downloadgentoo-de035788fb8ceddd4a7b3fd038537f2e530009f1.tar.gz
gentoo-de035788fb8ceddd4a7b3fd038537f2e530009f1.tar.bz2
gentoo-de035788fb8ceddd4a7b3fd038537f2e530009f1.zip
dev-lang/R: new revision that leaves more docs uncompressed.
The R interactive shell encourages users to read several documentation files using functions like contributors() and RShowDoc() that rely on the files being installed with their god-given names. This new revision tries to fix a few of the more common ones with docompress -x. Closes: https://bugs.gentoo.org/556706 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/R-3.6.3-r1.ebuild (renamed from dev-lang/R/R-3.6.3.ebuild)32
1 files changed, 31 insertions, 1 deletions
diff --git a/dev-lang/R/R-3.6.3.ebuild b/dev-lang/R/R-3.6.3-r1.ebuild
index f797705dcd70..0f45bd0490e6 100644
--- a/dev-lang/R/R-3.6.3.ebuild
+++ b/dev-lang/R/R-3.6.3-r1.ebuild
@@ -189,7 +189,37 @@ src_install() {
done
popd > /dev/null
fi
- docompress -x /usr/share/doc/${PF}/{BioC_mirrors.csv,CRAN_mirrors.csv,KEYWORDS.db,NEWS.rds}
+
+ # Users are encouraged to access some of the the R documentation
+ # interactively, through functions like "contributors()" that
+ # tries to open the "AUTHORS" file. Other files can be accessed
+ # by name with RShowDoc(), and the documentation for e.g. license()
+ # and RShowDoc() suggests a few of these names. Here we try to
+ # collect as many names as possible that a user might actually
+ # try to view through R, because if we don't decompress them,
+ # then R doesn't know what to do with 'em. Bug #556706.
+ INTERACTIVE_DOCS=(
+ AUTHORS
+ COPYING
+ FAQ
+ NEWS
+ THANKS
+ )
+
+ # Other data sources that are shipped as "documentation," but which
+ # need to be accessible via their original unmolested filenames.
+ INTERACTIVE_DATA=(
+ BioC_mirrors.csv
+ CRAN_mirrors.csv
+ KEYWORDS.db
+ NEWS.rds
+ )
+
+ NOCOMPRESS_DOCS=( "${INTERACTIVE_DOCS[@]}" "${INTERACTIVE_DATA[@]}" )
+
+ for f in "${NOCOMPRESS_DOCS[@]}"; do
+ docompress -x "/usr/share/doc/${PF}/${f}"
+ done
}
pkg_postinst() {