summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-02-06 17:04:59 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-15 20:25:23 -0500
commit577a619d261ced4c6c84f7196ea5c427ee2e95c3 (patch)
treed25b62dbeef8fd6a6e8ea6a1ffd70a8eb6ac1dab /dev-cpp/libxmlpp/libxmlpp-3.0.1-r1.ebuild
parentdev-cpp/gtksourceviewmm: Specify the atkmm+cairomm slots (diff)
downloadgentoo-577a619d261ced4c6c84f7196ea5c427ee2e95c3.tar.gz
gentoo-577a619d261ced4c6c84f7196ea5c427ee2e95c3.tar.bz2
gentoo-577a619d261ced4c6c84f7196ea5c427ee2e95c3.zip
dev-cpp/libxmlpp: Specify the glibmm slot
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-cpp/libxmlpp/libxmlpp-3.0.1-r1.ebuild')
-rw-r--r--dev-cpp/libxmlpp/libxmlpp-3.0.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/libxmlpp/libxmlpp-3.0.1-r1.ebuild b/dev-cpp/libxmlpp/libxmlpp-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..06c753d80b95
--- /dev/null
+++ b/dev-cpp/libxmlpp/libxmlpp-3.0.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME_ORG_MODULE="${PN/pp/++}"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ wrapper for the libxml2 XML parser library"
+HOMEPAGE="http://libxmlplusplus.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="3.0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-libs/libxml2-2.7.7[${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.32:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+multilib_src_prepare() {
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure \
+ $(use_enable doc documentation)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}