summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-23 20:22:39 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-23 20:24:18 +0200
commite319d10963f94dfdc4c715a33f3ba23f4b3ec20b (patch)
tree095f5af7ca8c84110b661ae16508ef65fd8fd503 /app-text/zotero-bin
parentpackage.mask: mask 0.15.0 version of janestreet packages (diff)
downloadgentoo-e319d10963f94dfdc4c715a33f3ba23f4b3ec20b.tar.gz
gentoo-e319d10963f94dfdc4c715a33f3ba23f4b3ec20b.tar.bz2
gentoo-e319d10963f94dfdc4c715a33f3ba23f4b3ec20b.zip
app-text/zotero-bin: add 6.0.5
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text/zotero-bin')
-rw-r--r--app-text/zotero-bin/Manifest1
-rw-r--r--app-text/zotero-bin/zotero-bin-6.0.5.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-text/zotero-bin/Manifest b/app-text/zotero-bin/Manifest
index 3db1e5b00afb..d67a59b24391 100644
--- a/app-text/zotero-bin/Manifest
+++ b/app-text/zotero-bin/Manifest
@@ -1,2 +1,3 @@
DIST zotero-bin-5.0.96.3.tar.bz2 61236517 BLAKE2B 3de6d41349f9cc405dd3d44e8e456169d58bdd1f4522c31cd168182878839fe8ca6280eff7339bcf3d66c87c7d4f5af55d768551abcff3cd579342cae37b64e3 SHA512 0777ec41bc151b0bd30076f8a7f59e431c3435728b4d85298421ef11aea5b7c1e122d3bb7fcc5551bb8c4472922796d9508a56df7a0913515d8568fcf3ca6fee
DIST zotero-bin-6.0.4.tar.bz2 68409133 BLAKE2B 9aeb7cfc8e12f7cdd8aa595fa46564d873c51603295f2dd802ba7ad8baaf59e366fb85d5b98c6614222f98449c800e58b7fb190cbb80a1991beb0c69669d6da2 SHA512 14f759dab9e02253f7be8269575fabedc79556cc81eb1bcfaa5d945280b174545b9f23b2c190824124503f353af6a0416c15ecea99a81f5f000207a1eefe84b9
+DIST zotero-bin-6.0.5.tar.bz2 68482314 BLAKE2B 77c17665b8584b828764a07012f3f91237dc73b334a9635fe50fae9da1ca20901a7bab22ef7008baf14c60209fc0ed9d1f6791c0a4bf3bd9414713a1071c9685 SHA512 568583c44436d9830e0b9271bfaedf7380556498c757de0bcea07ba97202aa853f92501c9aa755637ba4810d266a43c2ee17a1eedef564d22821e7f4ee337ff0
diff --git a/app-text/zotero-bin/zotero-bin-6.0.5.ebuild b/app-text/zotero-bin/zotero-bin-6.0.5.ebuild
new file mode 100644
index 000000000000..b9f2fd5004e0
--- /dev/null
+++ b/app-text/zotero-bin/zotero-bin-6.0.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Helps you collect, organize, cite, and share your research sources"
+HOMEPAGE="https://www.zotero.org"
+SRC_URI="https://www.zotero.org/download/client/dl?channel=release&platform=linux-x86_64&version=${PV} -> ${P}.tar.bz2"
+S="${WORKDIR}/Zotero_linux-x86_64"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ dev-libs/atk
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-apps/dbus
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/zotero/*"
+
+src_prepare() {
+ # disable auto-update
+ sed -i -e 's/\(pref("app.update.enabled"\).*/\1, false);/' defaults/preferences/prefs.js || die
+
+ # disable default oo installation questions - manual installation is still possible
+ sed -i -e 's/\(pref("extensions.zoteroOpenOfficeIntegration.skipInstallation"\).*/\1, true);/' \
+ extensions/zoteroOpenOfficeIntegration@zotero.org/defaults/preferences/zoteroOpenOfficeIntegration.js || die
+
+ # fix desktop-file
+ sed -i -e 's#^Exec=.*#Exec=zotero#' zotero.desktop || die
+ sed -i -e 's#Icon=zotero.*#Icon=zotero#' zotero.desktop || die
+
+ default
+}
+
+src_install() {
+ dodir opt/zotero
+ cp -a "${S}"/* "${ED}/opt/zotero" || die
+
+ dosym ../../opt/zotero/zotero usr/bin/zotero
+
+ domenu zotero.desktop
+
+ for size in 16 32 48 256; do
+ newicon -s ${size} chrome/icons/default/default${size}.png zotero.png
+ done
+}