summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/crf++
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/crf++')
-rw-r--r--app-text/crf++/Manifest2
-rw-r--r--app-text/crf++/crf++-0.54.ebuild59
-rw-r--r--app-text/crf++/crf++-0.58.ebuild56
-rw-r--r--app-text/crf++/files/crf++-0.54-gcc46.patch11
-rw-r--r--app-text/crf++/metadata.xml12
5 files changed, 140 insertions, 0 deletions
diff --git a/app-text/crf++/Manifest b/app-text/crf++/Manifest
new file mode 100644
index 000000000000..244a6f7c771e
--- /dev/null
+++ b/app-text/crf++/Manifest
@@ -0,0 +1,2 @@
+DIST CRF++-0.54.tar.gz 809008 SHA256 8dab6e9ab71212b3d223588f6855384f2b29dada0a30d450266f8990ced63354 SHA512 4198ad9423776a44d02db51a655a35f36db767ec623f55de426b3415179ac7187b91d23c6ef9a2cf3d1c38e14507fc7681006ff2ba50dcfc771a7d5e9d1c5760 WHIRLPOOL 6e09affc37cee8bda9df1b7a919f386e026f4218a5ccda7e677b7a172887aba7af85db2357ea1ec51c8122115bb558183e242315d2991b4745df6ce90835cda4
+DIST CRF++-0.58.tar.gz 790570 SHA256 9d1c0a994f25a5025cede5e1d3a687ec98cd4949bfb2aae13f2a873a13259cb2 SHA512 676b3e9ed89b5fb2f246175b58c384f10cab09fff8329c07311fed3832f55dbad26a25d2946c9efaa75cd8026517cb9e1742bb70ca26187367747852073e4eb9 WHIRLPOOL 87f642639c0d670a7926d99630f2230fffbbea1e02976fc8f47dc580dcbfffdca6e2e066445e7bd28fb517dd5f3798af9fda6549c54fd5278f3570befc155ee6
diff --git a/app-text/crf++/crf++-0.54.ebuild b/app-text/crf++/crf++-0.54.ebuild
new file mode 100644
index 000000000000..c1dd5c143f6e
--- /dev/null
+++ b/app-text/crf++/crf++-0.54.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit autotools eutils
+
+MY_P="${P/crf/CRF}"
+DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
+HOMEPAGE="http://crfpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crfpp/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="examples static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+
+ # bug #365921
+ epatch "${FILESDIR}/${P}-gcc46.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) || die
+}
+
+src_test() {
+ for task in example/* ; do
+ (
+ cd "${task}"
+ ./exec.sh || die "failed test in ${task}"
+ )
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ dodoc AUTHORS README || die
+ dohtml -r doc/* || die
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example || die
+ fi
+}
diff --git a/app-text/crf++/crf++-0.58.ebuild b/app-text/crf++/crf++-0.58.ebuild
new file mode 100644
index 000000000000..43455b48df35
--- /dev/null
+++ b/app-text/crf++/crf++-0.58.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit autotools eutils
+
+MY_P="${P/crf/CRF}"
+DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
+HOMEPAGE="http://crfpp.googlecode.com/svn/trunk/doc/index.html"
+SRC_URI="http://crfpp.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="examples static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) || die
+}
+
+src_test() {
+ for task in example/* ; do
+ (
+ cd "${task}"
+ ./exec.sh || die "failed test in ${task}"
+ )
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -type f -delete || die
+ fi
+
+ dodoc AUTHORS README || die
+ dohtml -r doc/* || die
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example || die
+ fi
+}
diff --git a/app-text/crf++/files/crf++-0.54-gcc46.patch b/app-text/crf++/files/crf++-0.54-gcc46.patch
new file mode 100644
index 000000000000..93cb54020cfc
--- /dev/null
+++ b/app-text/crf++/files/crf++-0.54-gcc46.patch
@@ -0,0 +1,11 @@
+diff -Naur CRF++-0.54.orig/path.h CRF++-0.54/path.h
+--- CRF++-0.54.orig/path.h 2009-04-05 20:42:35.000000000 +0900
++++ CRF++-0.54/path.h 2011-05-31 01:31:43.845198215 +0900
+@@ -8,6 +8,7 @@
+ #ifndef CRFPP_PATH_H_
+ #define CRFPP_PATH_H_
+
++#include <cstddef>
+ #include <vector>
+ #include "node.h"
+
diff --git a/app-text/crf++/metadata.xml b/app-text/crf++/metadata.xml
new file mode 100644
index 000000000000..0b1609859c4e
--- /dev/null
+++ b/app-text/crf++/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <longdescription lang="en">
+ CRF++ is a simple, customizable, and open source implementation
+ of Conditional Random Fields (CRFs) for segmenting/labeling
+ sequential data. CRF++ is designed for generic purpose and will be
+ applied to a lot of NLP tasks, such as Named Entity Recognition,
+ Information Extraction and Text Chunking.
+ </longdescription>
+</pkgmetadata>