summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/ledger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/ledger')
-rw-r--r--app-office/ledger/Manifest2
-rw-r--r--app-office/ledger/files/50ledger-gentoo.el5
-rw-r--r--app-office/ledger/ledger-2.6.3-r1.ebuild81
-rw-r--r--app-office/ledger/ledger-3.1.ebuild27
-rw-r--r--app-office/ledger/metadata.xml10
5 files changed, 125 insertions, 0 deletions
diff --git a/app-office/ledger/Manifest b/app-office/ledger/Manifest
new file mode 100644
index 000000000000..40a419e1b4d4
--- /dev/null
+++ b/app-office/ledger/Manifest
@@ -0,0 +1,2 @@
+DIST ledger-2.6.3.tar.gz 551325 SHA256 e2c99d930fcf64b7fa901215c7fa25e3327f6365e8ee049620ef3632d53bf363 SHA512 825e670d25d2f8d1791480fb5da4190f7b342ecc9b47bca60fd6f0e606e5af5f3f767ec7043339660396ef4c90451f4a4122d812b8761acf4ea964b67dbd43b5 WHIRLPOOL e6d351ce8899079daa9cb0d1f9493b2b551a6d44e8ad7949c28ac8e544f80c87d54f06b350adfc21c4c8582e9042547313a506fa74096671bae30b462ae3e2df
+DIST ledger-3.1.tar.gz 817624 SHA256 eeb5d260729834923fc94822bcc54ca3080c434f81466a3f5dc4274b357ce694 SHA512 caa84330eee05d3e88820e8afd4a906d22f6aaa9de4abc2f6813636754e052e6ec4d1b3d2fce68215aededc72651405c62aaf16a2c1b69d34e1b10ffece48519 WHIRLPOOL fc3ce5e8eb59e1d4f83101063ebefd1379172c1be0e4f504079519924859b8127d616e7e3714837be49c7b38674b1684e321347d1f8561aeeba586b538341142
diff --git a/app-office/ledger/files/50ledger-gentoo.el b/app-office/ledger/files/50ledger-gentoo.el
new file mode 100644
index 000000000000..27836612139f
--- /dev/null
+++ b/app-office/ledger/files/50ledger-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; app-office/ledger site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ledger-mode "ledger" "A mode for editing ledger data files." t)
diff --git a/app-office/ledger/ledger-2.6.3-r1.ebuild b/app-office/ledger/ledger-2.6.3-r1.ebuild
new file mode 100644
index 000000000000..d53486961020
--- /dev/null
+++ b/app-office/ledger/ledger-2.6.3-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils elisp-common autotools
+
+DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
+HOMEPAGE="http://ledger-cli.org/"
+SRC_URI="mirror://github/jwiegley/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos"
+SLOT="0"
+IUSE="emacs debug gnuplot ofx static-libs xml vim-syntax"
+
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/libpcre
+ ofx? ( >=dev-libs/libofx-0.9 )
+ xml? ( dev-libs/expat )
+ emacs? ( virtual/emacs )
+ gnuplot? ( sci-visualization/gnuplot )"
+RDEPEND="${DEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+DOCS=(sample.dat README NEWS)
+
+SITEFILE=50${PN}-gentoo.el
+
+src_prepare() {
+ sed -i -e "/ledger_LDFLAGS/d" Makefile.am
+ eautoreconf
+}
+
+src_configure() {
+ # Autodetection of dependencies may fail in the case of:
+ # USE=emacs disabled, app-editors/emacs not installed, app-editors/xemacs installed
+ use emacs || export EMACS=no
+ econf \
+ $(use_enable debug) \
+ $(use_with emacs lispdir "${EPREFIX}/${SITELISP}/${PN}") \
+ $(use_enable ofx) \
+ $(use_enable static-libs static) \
+ $(use_enable xml)
+}
+
+src_install() {
+ default
+
+ # One script uses vi, the outher the Finance perl module
+ # Did not add more use flags though
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/{entry,getquote,bal,bal-huquq}
+
+ # Remove timeclock since it is part of Emacs
+ rm -f "${ED}${SITELISP}/${PN}"/timeclock.*
+
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ if use gnuplot; then
+ mv scripts/report ledger-report
+ dobin ledger-report
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ledger.vim
+ fi
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f '{}' +
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/app-office/ledger/ledger-3.1.ebuild b/app-office/ledger/ledger-3.1.ebuild
new file mode 100644
index 000000000000..6cdf9d9a5148
--- /dev/null
+++ b/app-office/ledger/ledger-3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
+HOMEPAGE="http://ledger-cli.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/gmp:0
+ dev-libs/mpfr:0
+"
+DEPEND="${RDEPEND}
+ dev-libs/utfcpp
+"
+
+DOCS=(README.md)
diff --git a/app-office/ledger/metadata.xml b/app-office/ledger/metadata.xml
new file mode 100644
index 000000000000..884bd5bcd0a3
--- /dev/null
+++ b/app-office/ledger/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yac@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ledger/ledger</remote-id>
+ </upstream>
+</pkgmetadata>