summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-19 00:50:12 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-19 00:50:12 +0900
commit496709371aaada0a52bf2e8028bbb0f70bff06c7 (patch)
treedec0c7b4f3b69640a13af8fa7b3c9b45d8dba4d4 /app-i18n/kimera
parentapp-i18n/kimera: update to EAPI 6 (diff)
downloadgentoo-496709371aaada0a52bf2e8028bbb0f70bff06c7.tar.gz
gentoo-496709371aaada0a52bf2e8028bbb0f70bff06c7.tar.bz2
gentoo-496709371aaada0a52bf2e8028bbb0f70bff06c7.zip
app-i18n/kimera: add support for app-i18n/imsettings
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-i18n/kimera')
-rw-r--r--app-i18n/kimera/files/xinput-kimera4
-rw-r--r--app-i18n/kimera/kimera-2.11-r2.ebuild44
2 files changed, 48 insertions, 0 deletions
diff --git a/app-i18n/kimera/files/xinput-kimera b/app-i18n/kimera/files/xinput-kimera
new file mode 100644
index 000000000000..080c0233af49
--- /dev/null
+++ b/app-i18n/kimera/files/xinput-kimera
@@ -0,0 +1,4 @@
+XIM=kimera
+XIM_PROGRAM="@EPREFIX@/usr/bin/kimera"
+GTK_IM_MODULE=xim
+QT_IM_MODULE=xim
diff --git a/app-i18n/kimera/kimera-2.11-r2.ebuild b/app-i18n/kimera/kimera-2.11-r2.ebuild
new file mode 100644
index 000000000000..2be50304e3ba
--- /dev/null
+++ b/app-i18n/kimera/kimera-2.11-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit qmake-utils
+
+DESCRIPTION="A Japanese input method which supports the XIM protocol"
+HOMEPAGE="http://kimera.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/37271/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+anthy"
+
+RDEPEND="dev-qt/qt3support:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ anthy? ( app-i18n/anthy )
+ !anthy? ( app-i18n/canna )"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-underlinking.patch )
+
+src_configure() {
+ local myconf=(
+ script.path="${EPREFIX}"/usr/bin
+ target.path="${EPREFIX}"/usr/$(get_libdir)/${P}
+ no_anthy=$(usex anthy 1 0)
+ )
+ eqmake4 ${PN}.pro "${myconf[@]}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ insinto /etc/X11/xinit/xinput.d
+ sed \
+ -e "s:@EPREFIX@:${EPREFIX}:g" \
+ "${FILESDIR}"/xinput-${PN} > "${T}"/${PN}.conf
+ doins "${T}"/${PN}.conf
+}