summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-17 15:35:35 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-17 15:36:36 +0200
commit761b42c9fdae7c8cd01615be8d2b4f6cad5c3443 (patch)
tree48d5911a530617ee6e6fe8adb5df6a2e57050b7d /app-eselect/eselect-sh
parentapp-editors/curses-hexedit: Fix building with CFLAGS=-fno-common (diff)
downloadgentoo-761b42c9fdae7c8cd01615be8d2b4f6cad5c3443.tar.gz
gentoo-761b42c9fdae7c8cd01615be8d2b4f6cad5c3443.tar.bz2
gentoo-761b42c9fdae7c8cd01615be8d2b4f6cad5c3443.zip
app-eselect/eselect-sh: Remove posh from targets
Closes: https://bugs.gentoo.org/720996 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-eselect/eselect-sh')
-rw-r--r--app-eselect/eselect-sh/eselect-sh-0.4.1.ebuild21
-rw-r--r--app-eselect/eselect-sh/files/sh.eselect-0.4.113
2 files changed, 34 insertions, 0 deletions
diff --git a/app-eselect/eselect-sh/eselect-sh-0.4.1.ebuild b/app-eselect/eselect-sh/eselect-sh-0.4.1.ebuild
new file mode 100644
index 000000000000..2d22ada5e0b1
--- /dev/null
+++ b/app-eselect/eselect-sh/eselect-sh-0.4.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manages the /bin/sh (POSIX shell) symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-eselect/eselect-lib-bin-symlink"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/sh.eselect-${PV} sh.eselect
+}
diff --git a/app-eselect/eselect-sh/files/sh.eselect-0.4.1 b/app-eselect/eselect-sh/files/sh.eselect-0.4.1
new file mode 100644
index 000000000000..286c321816d9
--- /dev/null
+++ b/app-eselect/eselect-sh/files/sh.eselect-0.4.1
@@ -0,0 +1,13 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /bin/sh (POSIX shell) implementations"
+MAINTAINER="mgorny@gentoo.org"
+VERSION="0.4.1"
+
+SYMLINK_PATH=/bin/sh
+SYMLINK_TARGETS=( bash dash mksh )
+SYMLINK_DESCRIPTION='POSIX shell'
+SYMLINK_CRUCIAL=1
+
+inherit bin-symlink