summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/ocaml-mode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/ocaml-mode')
-rw-r--r--app-emacs/ocaml-mode/Manifest2
-rw-r--r--app-emacs/ocaml-mode/files/50ocaml-mode-gentoo-3.12.1.el10
-rw-r--r--app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el10
-rw-r--r--app-emacs/ocaml-mode/metadata.xml6
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.12.1-r1.ebuild20
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-3.12.1.ebuild22
-rw-r--r--app-emacs/ocaml-mode/ocaml-mode-4.00.1.ebuild20
7 files changed, 90 insertions, 0 deletions
diff --git a/app-emacs/ocaml-mode/Manifest b/app-emacs/ocaml-mode/Manifest
new file mode 100644
index 000000000000..b6602e1fa506
--- /dev/null
+++ b/app-emacs/ocaml-mode/Manifest
@@ -0,0 +1,2 @@
+DIST ocaml-3.12.1.tar.bz2 2949124 SHA256 edcf563da75e0b91f09765649caa98ab1535e0c7498f0737b5591b7de084958d SHA512 cbb050aabcbe19a4aa070d6cb74f3774cb136692dfd9433ca977f0f9520ad2f583b6cfb1a9cedfedc92e7dc794ac4a869e20aa5a67a4739002feb290435dc7e7 WHIRLPOOL b7bf4844452ab52027e6b785159df6e4defc548d2f3d31eb73dc0dc05214e7c19ed654c8b3ff234a85691599df0be568ba02fafe257856be7f603177584a7ca0
+DIST ocaml-4.00.1.tar.bz2 2762205 SHA256 33c3f4acff51685f5bfd7c260f066645e767d4e865877bf1613c176a77799951 SHA512 77899430706394af558666361b152d47df3a3e21831059875f8b317d0ff9d1a010177bf1e5851e522e086c20768e92c71344aa53eda0ce003f278752870ab5da WHIRLPOOL 3fdc090e1158ae72c91685aef62c751f897f4e3efcfbdc07e00d92e83351494fd126bdaca31039c1bf5dc4107072d978bb30e02c879caafc215dbc913f2d6ed1
diff --git a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo-3.12.1.el b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo-3.12.1.el
new file mode 100644
index 000000000000..bea123308024
--- /dev/null
+++ b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo-3.12.1.el
@@ -0,0 +1,10 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.ml[iylp]?\\'" . caml-mode))
+(autoload 'caml-mode "caml" "Major mode for editing Caml code." t)
+(autoload 'run-caml "inf-caml" "Run an inferior Caml process." t)
+(autoload 'camldebug "camldebug"
+ "Run camldebug on program FILE in buffer *camldebug-FILE*." t)
+(autoload 'inferior-caml-set-font-lock "caml-font")
+
+(eval-after-load "caml" '(require 'caml-font))
+(add-hook 'inferior-caml-mode-hooks 'inferior-caml-set-font-lock)
diff --git a/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
new file mode 100644
index 000000000000..8f45033a3fce
--- /dev/null
+++ b/app-emacs/ocaml-mode/files/50ocaml-mode-gentoo.el
@@ -0,0 +1,10 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.ml[iylp]?\\'" . caml-mode))
+(autoload 'caml-mode "caml" "Major mode for editing Caml code." t)
+(autoload 'run-caml "inf-caml" "Run an inferior Caml process." t)
+(autoload 'camldebug "camldebug"
+ "Run camldebug on program FILE in buffer *camldebug-FILE*." t)
+(autoload 'inferior-caml-mode-font-hook "caml-font")
+
+(eval-after-load "caml" '(require 'caml-font))
+(add-hook 'inferior-caml-mode-hooks 'inferior-caml-mode-font-hook)
diff --git a/app-emacs/ocaml-mode/metadata.xml b/app-emacs/ocaml-mode/metadata.xml
new file mode 100644
index 000000000000..d3eb2339e1fa
--- /dev/null
+++ b/app-emacs/ocaml-mode/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.12.1-r1.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.12.1-r1.ebuild
new file mode 100644
index 000000000000..1674d494eda6
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.12.1-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+MY_P=${P/-mode/}
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+
+S="${WORKDIR}/${MY_P}/emacs"
+SITEFILE="50${PN}-gentoo-${PV}.el"
+DOCS="README README.itz"
diff --git a/app-emacs/ocaml-mode/ocaml-mode-3.12.1.ebuild b/app-emacs/ocaml-mode/ocaml-mode-3.12.1.ebuild
new file mode 100644
index 000000000000..00b718954e09
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-3.12.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+MY_P=${P/-mode/}
+
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}/emacs"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="README README.itz"
diff --git a/app-emacs/ocaml-mode/ocaml-mode-4.00.1.ebuild b/app-emacs/ocaml-mode/ocaml-mode-4.00.1.ebuild
new file mode 100644
index 000000000000..b51729bb386d
--- /dev/null
+++ b/app-emacs/ocaml-mode/ocaml-mode-4.00.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+MY_P=${P/-mode/}
+DESCRIPTION="Emacs mode for OCaml"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/${MY_P%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
+
+S="${WORKDIR}/${MY_P}/emacs"
+SITEFILE="50${PN}-gentoo-3.12.1.el"
+DOCS="README README.itz"