summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-01-02 11:14:31 +0100
committerUlrich Müller <ulm@gentoo.org>2021-01-02 15:02:10 +0100
commit676d75b9277896e54cbc8c3cc5632e55842c9413 (patch)
treeea7a57eb97913db214a5e4d44c83289208008200 /app-editors
parentdev-python/ipython: Prevent use with dev-python/jedi-0.18.0 (diff)
downloadgentoo-676d75b9277896e54cbc8c3cc5632e55842c9413.tar.gz
gentoo-676d75b9277896e54cbc8c3cc5632e55842c9413.tar.bz2
gentoo-676d75b9277896e54cbc8c3cc5632e55842c9413.zip
app-editors/zile: Version bump to 2.4.15
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/zile/Manifest1
-rw-r--r--app-editors/zile/zile-2.4.15.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/zile/Manifest b/app-editors/zile/Manifest
index 70e83d7e2d8a..639d68d90875 100644
--- a/app-editors/zile/Manifest
+++ b/app-editors/zile/Manifest
@@ -1,2 +1,3 @@
DIST zile-2.3.24.tar.gz 953962 BLAKE2B 242f0f9532a536d5ba36664031cf86eba753239c0f6dcd47c086496628a730bdd0a9112dc1ffd26965068f6d66d35d3ad3c92fc2753e129adf9a5923321e2cdf SHA512 8361f42436ae9ca150f09d830096b7a3fb0089d58bffe5ad7538b5ec5cd4e0e50085213e938db1a95e2922db845d1d2f36841a65fe1b9b72f60cd930dd8f09b9
DIST zile-2.4.14.tar.gz 1385314 BLAKE2B 43815e87bb037a8de42b00510ce8addd748fe2a639f78e736c7fe6220c972ce600a8db557dd592065bb27e1d35a5d3a42b6a4a8d5d76eefc4274a8ce27b1d9c2 SHA512 0dea56fd13a82015ec73de3139a4b2c27ad4c001ed535f1bae557ee49f9d8a188610a08160998d0a36b95fec42b46a019fd43634ef6502ebd27e162164de98cc
+DIST zile-2.4.15.tar.gz 1490611 BLAKE2B 3744ab2459edf9b0dc9ca976c5f37625d06e0766e3a1fbb59112fe375af6f6cc5e8c068dcb127b338091f3130d32190ad4bc3a79eac7f9a4f87b46723d5a4a82 SHA512 e2a04c280ae0c0038e6ef18abec0be55063a472f77a511bf31459712be24659edcaa2d1c861d7c00bdab87a1881af03d14eb561047c386cbff5f90b13b1a2575
diff --git a/app-editors/zile/zile-2.4.15.ebuild b/app-editors/zile/zile-2.4.15.ebuild
new file mode 100644
index 000000000000..16a2248ef54d
--- /dev/null
+++ b/app-editors/zile/zile-2.4.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Zile is a small Emacs clone"
+HOMEPAGE="https://www.gnu.org/software/zile/"
+SRC_URI="mirror://gnu/zile/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="acl"
+
+RDEPEND=">=dev-libs/boehm-gc-7.2:=
+ sys-libs/ncurses:0=
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="dev-lang/perl
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+# AUTHORS, FAQ, and NEWS are installed by the build system
+DOCS="README THANKS"
+
+QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
+
+src_configure() {
+ econf \
+ $(use_enable acl) \
+ CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_test() {
+ if tput cup 0 0 >/dev/null || tput cuu1 >/dev/null; then
+ # We have a sane terminal that can move the cursor
+ emake check
+ else
+ ewarn "Terminal type \"${TERM}\" is too stupid to run zile"
+ ewarn "Running the tests with unset TERM instead"
+ ( unset TERM; emake check )
+ fi
+}