summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-11-07 22:40:33 +0100
committerUlrich Müller <ulm@gentoo.org>2023-11-07 22:41:15 +0100
commit2263720251494e99337b8e38d43196d28fb117f3 (patch)
treeb135a68e3ea1a7b6f3e1d065bab68b2732d851b3 /app-editors
parentdev-python/cherrypy: Add GH remote-id (diff)
downloadgentoo-2263720251494e99337b8e38d43196d28fb117f3.tar.gz
gentoo-2263720251494e99337b8e38d43196d28fb117f3.tar.bz2
gentoo-2263720251494e99337b8e38d43196d28fb117f3.zip
app-editors/jove: add 4.17.5.3
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/jove/Manifest1
-rw-r--r--app-editors/jove/jove-4.17.5.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/jove/Manifest b/app-editors/jove/Manifest
index 5528d9543721..8829818bbfd3 100644
--- a/app-editors/jove/Manifest
+++ b/app-editors/jove/Manifest
@@ -1,2 +1,3 @@
DIST jove-4.17.3.7.tar.gz 490070 BLAKE2B bfe95cc8f78993438839b93ebf37567940449e3914dd1963728ee82dc601c371318a34ea0d5d13d9d4dccaf9c4750874c5e0d3af22dcb2421595dca2da7cafdf SHA512 90bd597bb4be3a4589f77ee331cee4fa2784264221fe6247c2535ae34c5689c08f55c2b2919bff34af5631b73b12883dab54df9770b4157ae801079a23222d9a
+DIST jove-4.17.5.3.tar.gz 548835 BLAKE2B 12b1f16d82e84cc2d099e2f45f5a42e2d1e811e5a9685c7ee162280ef49ecef8f7955a98679b60c49bbeaa30e3a430b1d6fc969270bee02862ff284a932829d9 SHA512 f91bdf3145ad243cfe8a4d9aca497a3d2cc58711488fa6b845d0d5e70dece6939046743aae1f18fd2614d75420bb747b00e61bb60b13ff35b26409068df40127
DIST jove4.16.0.73.tgz 465214 BLAKE2B cc1eeca2cdbd7ca98a5deaf27c37bfcdc529f2b388361e0cd5fd6278b72740a06283abd1f60212e6dc0d1e540e4dc4d99edb99b781645b13e1675644db0f38eb SHA512 2198504f9a23590710acba7f27661fa5649fdbed559a4c6bde9d2c1d673c22ce7d99a690be45a4602d37cf6e70399230c4ae3a251d8451af0c5252bdca61b09d
diff --git a/app-editors/jove/jove-4.17.5.3.ebuild b/app-editors/jove/jove-4.17.5.3.ebuild
new file mode 100644
index 000000000000..503b10d07000
--- /dev/null
+++ b/app-editors/jove/jove-4.17.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Jonathan's Own Version of Emacs, a light emacs-like editor without LISP bindings"
+HOMEPAGE="https://github.com/jonmacs/jove"
+SRC_URI="https://github.com/jonmacs/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="JOVE"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ tc-export CC
+
+ myopts=(
+ JOVEHOME="${EPREFIX}/usr" \
+ JMANDIR="${EPREFIX}/usr/share/man/man1" \
+ JDOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ OPTFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ LDLIBS="$("$(tc-getPKG_CONFIG)" --libs ncurses)" \
+ SYSDEFS="-DLinux" \
+ $(usev !doc FREFDOCS="")
+ )
+ emake "${myopts[@]}"
+}
+
+src_install() {
+ # The Makefile triggers a rebuild if any of the options have changed
+ # (see recipe for keys.c). So we must pass identical options even if
+ # they're not needed for installation.
+ emake "${myopts[@]}" DESTDIR="${D}" install
+
+ keepdir /var/lib/jove/preserve
+ dodoc README
+}