summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-27 23:33:41 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-28 00:33:18 -0400
commit836c1411aaee2daf8eed3ba65a17e8c96f269728 (patch)
tree01b7c67902caf7864f3deb47c86c4cea720b99e4 /app-editors/gvim
parentapp-editors/vim: sync more details with gvim ebuild (diff)
downloadgentoo-836c1411aaee2daf8eed3ba65a17e8c96f269728.tar.gz
gentoo-836c1411aaee2daf8eed3ba65a17e8c96f269728.tar.bz2
gentoo-836c1411aaee2daf8eed3ba65a17e8c96f269728.zip
app-editors/gvim: sync more details with vim ebuild
Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'app-editors/gvim')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 44b852c8973c..b9e03f4a2866 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -68,7 +68,8 @@ RDEPEND="
tcl? ( dev-lang/tcl:0= )
"
DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ x11-base/xorg-proto
+"
# configure runs the Lua interpreter
BDEPEND="
dev-build/autoconf
@@ -191,9 +192,15 @@ src_configure() {
fi
done
+ local myconf=(
+ --with-modified-by="Gentoo-${PVR} (RIP Bram)"
+ --with-vim-name=gvim
+ --with-x
+ )
+
use debug && append-flags "-DDEBUG"
- local myconf=(
+ myconf+=(
--with-features=huge
--disable-gpm
--with-gnome=no
@@ -251,11 +258,7 @@ src_configure() {
vim_cv_toupper_broken=no
fi
- econf \
- --with-modified-by="Gentoo-${PVR} (RIP Bram)" \
- --with-vim-name=gvim \
- --with-x \
- "${myconf[@]}"
+ econf "${myconf[@]}"
}
src_compile() {