summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-14 12:20:20 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-14 12:20:46 -0400
commitc0d2b0d1297c43e69dfcdc1cc56bc1998701c9e4 (patch)
treee27eb8d6a848940960fc48b981ec4bbc98d25a4a /app-editors/gnome-text-editor
parentsys-apps/memtest86+: keyword 6.00_beta2 for ~amd64, ~x86 (diff)
downloadgentoo-c0d2b0d1297c43e69dfcdc1cc56bc1998701c9e4.tar.gz
gentoo-c0d2b0d1297c43e69dfcdc1cc56bc1998701c9e4.tar.bz2
gentoo-c0d2b0d1297c43e69dfcdc1cc56bc1998701c9e4.zip
app-editors/gnome-text-editor: Version bump to 42.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/gnome-text-editor')
-rw-r--r--app-editors/gnome-text-editor/Manifest1
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-42.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index 8e46eef39998..25d0c49598e0 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1 +1,2 @@
DIST gnome-text-editor-42.1.tar.xz 1131572 BLAKE2B 8d1b59131d8230af0dc9e3029798f1200b6a00f8991e912c34ce4808ca5517e14763825aa8ed7aecdac88e422e9d224d3c027282f6373c023c4ffe9f3e4896b6 SHA512 4616750d15d61b2bd2c708e414b564d0aa6c1202c765fbb895e60cdb46f8335fbefa70a24e8d99f208b186f2c8c244b752475cefdbe0184a67b60de116d5ac2f
+DIST gnome-text-editor-42.2.tar.xz 1168504 BLAKE2B 0bbd02fab92c3ac2df2a38352561dda27662b4ede30d9cfd05b54d58c4dc4824375ee427e764415dc450a2f8dd793ba539e5681df984a20b1d121bd97a3f3008 SHA512 4373b048118c7a4253fe99a6ec6091c054154399d34e5a33f933d535f0e6c659023603e08e1cbcddb972d6385632b2b9351455eaa1398dcd7c50b3b4562400ae
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-42.2.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-42.2.ebuild
new file mode 100644
index 000000000000..979bb30ca006
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-42.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+SRC_URI="mirror://gnome/sources/gnome-text-editor/42/gnome-text-editor-${PV/_/.}.tar.xz"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-libs/glib-2.69:2
+ >=gui-libs/gtk-4.6:4
+ >=gui-libs/gtksourceview-5.4.1:5
+ gui-libs/libadwaita:1
+ dev-libs/libpcre
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}