summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-04 21:53:08 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-04 22:57:02 +0100
commit9cc524c5fbda07bfc424de0369cb7515afd72a76 (patch)
treef63ab37b8f7786601afe76f4e5c0d58c1c6741ff /app-containers
parentapp-containers/devcontainer: drop old 0.56.0 (diff)
downloadgentoo-9cc524c5fbda07bfc424de0369cb7515afd72a76.tar.gz
gentoo-9cc524c5fbda07bfc424de0369cb7515afd72a76.tar.bz2
gentoo-9cc524c5fbda07bfc424de0369cb7515afd72a76.zip
app-containers/devcontainer: bump to 0.57.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.57.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 138751424b73..d10bfc467b49 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1,2 +1,3 @@
DIST devcontainer-0.56.1.tgz 604649 BLAKE2B 887a034a9771843ce84be1b78d00ba7b52d09b64861f113d27e0dd662acabf175d4e7922a25826f2bf500ecc380473381ec05e307af0b7655535188240582700 SHA512 22f2d911b021f16181a1d954b31beaf323a84296be03489b6375729ea3ebcb198d58d3f731c40b8ec5ee20bfe26a933db1328a2d5278fa76686d965487924261
DIST devcontainer-0.56.2.tgz 617293 BLAKE2B 33eb4ae861934e78b9e73e77ed23ec1177e09785cf72dbdeb07e3d80e86ba1ac69f26bc01e150609cd20bc6c7895afc9b6118ae4d5007413b066986c75850a11 SHA512 188fdddad81a7f8cc5409e646c467fdc0722f0d7e45f3b24ea0614a9007c714ac9f8aff13f0e8a65f6c0e06e8769b1a4cba792a5575ce0733379ade45998fd27
+DIST devcontainer-0.57.0.tgz 617323 BLAKE2B 74dd49c0e741715e34dce79cdc73617f4bed68b87f11fafa403a9548b334ecff1af8e2e3705c57c31ca057e12b19094a75a3a3e339cac3b6d005e00e7e08b433 SHA512 7b5680d003630af459d5bf12f6873ea990a67b5f16888317a27d7197799d9ff1cd802834e669c4e1c601780fa8a07c38ec4dab77e7bf64de08406403e163e954
diff --git a/app-containers/devcontainer/devcontainer-0.57.0.ebuild b/app-containers/devcontainer/devcontainer-0.57.0.ebuild
new file mode 100644
index 000000000000..991cd956e37b
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.57.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}