summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:25:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-12 22:27:33 +0200
commit9a219810105d6b01d02aa6e7f6f43fe0025ebd5b (patch)
treeef5bf65f1b527b1978ad5d240f33839913ea3b0b
parentapp-text/libetonyek: Pin to =dev-util/mdds-1.4* (diff)
downloadgentoo-9a219810105d6b01d02aa6e7f6f43fe0025ebd5b.tar.gz
gentoo-9a219810105d6b01d02aa6e7f6f43fe0025ebd5b.tar.bz2
gentoo-9a219810105d6b01d02aa6e7f6f43fe0025ebd5b.zip
dev-libs/liborcus: Drop 0.13.4
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/liborcus/Manifest1
-rw-r--r--dev-libs/liborcus/files/liborcus-0.13.4-boost-1.67.patch50
-rw-r--r--dev-libs/liborcus/liborcus-0.13.4.ebuild59
3 files changed, 0 insertions, 110 deletions
diff --git a/dev-libs/liborcus/Manifest b/dev-libs/liborcus/Manifest
index 5ef7b99786f5..e358a2fd14f9 100644
--- a/dev-libs/liborcus/Manifest
+++ b/dev-libs/liborcus/Manifest
@@ -1,2 +1 @@
-DIST liborcus-0.13.4.tar.xz 1816340 BLAKE2B f8e7251c8688f82604d5ac1212938890e42f23ce45edb09eba9ab26a810e5fd4215a23dd20e86ddf9100db67818fc73fbbee7357642a6390f8f60dc28596be31 SHA512 f00b49c41eb1898c37d8d42e59f9004f46b5f849b9d60ac9c5033232d1e5065ff3de160e79f5a88983bf64f86e283b6d1d406a24e776aa6ff7b8acec324ccd4b
DIST liborcus-0.14.1.tar.xz 1894680 BLAKE2B 0070baf319bf35275f36f3082141f154404ad43d8143588b35c00b8b536f0c1cf5bf38fd9e997c4be45a454f16de1cc1a25186da40e3ed0606a87e9a6a968053 SHA512 a32dc5a652ce99cff37273c38fb9460e13e7bfb562f40c8d0c79b65c33e340daaeeb2c796308ca700b85bfc13cc8215641563b9e9f6d44b7d61adb8e8a3c950f
diff --git a/dev-libs/liborcus/files/liborcus-0.13.4-boost-1.67.patch b/dev-libs/liborcus/files/liborcus-0.13.4-boost-1.67.patch
deleted file mode 100644
index b1d44b8db4cb..000000000000
--- a/dev-libs/liborcus/files/liborcus-0.13.4-boost-1.67.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From f7485813af8e50f88c77312fb29b7bb489a0a17d Mon Sep 17 00:00:00 2001
-From: Adam Majer <amajer@suse.de>
-Date: Wed, 23 May 2018 10:45:56 +0200
-Subject: [PATCH] Fix build with Boost 1.67
-
-Boost:DateTime that no longer accepts non-integer types.
-In the past, these types were implicitly cast down to integer
-values. Now this requires explicit cast.
-
-https://svn.boost.org/trac10/ticket/11168
-
-This fixes #60
----
- src/spreadsheet/sheet.cpp | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/spreadsheet/sheet.cpp b/src/spreadsheet/sheet.cpp
-index 7df1aedb..33b372ad 100644
---- a/src/spreadsheet/sheet.cpp
-+++ b/src/spreadsheet/sheet.cpp
-@@ -289,7 +289,7 @@ void sheet::set_date_time(row_t row, col_t col, int year, int month, int day, in
-
- double days_since_epoch = (d - origin).days();
-
-- double ms = second * 1000000.0;
-+ long ms = second * 1000000.0;
-
- posix_time::time_duration t(
- posix_time::hours(hour) +
-@@ -606,7 +606,7 @@ date_time_t sheet::get_date_time(row_t row, col_t col) const
- if (time_fraction)
- {
- // Convert a fraction day to microseconds.
-- double ms = time_fraction * 24.0 * 60.0 * 60.0 * 1000000.0;
-+ long ms = time_fraction * 24.0 * 60.0 * 60.0 * 1000000.0;
- posix_time::time_duration td = posix_time::microsec(ms);
-
- hours = td.hours();
-@@ -615,7 +615,7 @@ date_time_t sheet::get_date_time(row_t row, col_t col) const
-
- td -= posix_time::hours(hours);
- td -= posix_time::minutes(minutes);
-- td -= posix_time::seconds(seconds);
-+ td -= posix_time::seconds((long)seconds);
-
- ms = td.total_microseconds(); // remaining microseconds.
-
---
-2.18.0
-
diff --git a/dev-libs/liborcus/liborcus-0.13.4.ebuild b/dev-libs/liborcus/liborcus-0.13.4.ebuild
deleted file mode 100644
index 81e4c1673a31..000000000000
--- a/dev-libs/liborcus/liborcus-0.13.4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://gitlab.com/orcus/orcus.git"
-
-PYTHON_COMPAT=( python{3_5,3_6} )
-
-[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
-inherit python-single-r1 ${GITECLASS}
-unset GITECLASS
-
-DESCRIPTION="Standalone file import filter library for spreadsheet documents"
-HOMEPAGE="https://gitlab.com/orcus/orcus/blob/master/README.md"
-[[ ${PV} == 9999 ]] || SRC_URI="https://kohei.us/files/orcus/src/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/0.13" # based on SONAME of liborcus.so
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="amd64 ~arm arm64 ~ppc ~ppc64 x86"
-IUSE="python +spreadsheet-model static-libs tools"
-
-RDEPEND="
- dev-libs/boost:=
- sys-libs/zlib
- python? ( ${PYTHON_DEPS} )
- spreadsheet-model? ( =dev-libs/libixion-0.13*:= )
-"
-DEPEND="${RDEPEND}
- =dev-util/mdds-1.3*:1
-"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=( "${FILESDIR}/${P}-boost-1.67.patch" )
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-werror \
- $(use_enable python) \
- $(use_enable spreadsheet-model) \
- $(use_enable static-libs static) \
- $(use_with tools)
-}
-
-src_install() {
- default
- find "${D}" -name '*.la' -delete || die
-}