summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-22 13:00:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-22 13:00:48 +0200
commit952c105c4a9089756e2382b634804f342ea9e7d8 (patch)
tree3881d1d48388caf781f5090141321192cfa0360f
parentapp-forensics/foremost: Stabilize 1.5.7-r4 amd64, #914516 (diff)
downloadgentoo-952c105c4a9089756e2382b634804f342ea9e7d8.tar.gz
gentoo-952c105c4a9089756e2382b634804f342ea9e7d8.tar.bz2
gentoo-952c105c4a9089756e2382b634804f342ea9e7d8.zip
dev-python/bibtexparser: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/bibtexparser/Manifest1
-rw-r--r--dev-python/bibtexparser/bibtexparser-1.4.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/bibtexparser/Manifest b/dev-python/bibtexparser/Manifest
index 07239be70e26..1284b94305cf 100644
--- a/dev-python/bibtexparser/Manifest
+++ b/dev-python/bibtexparser/Manifest
@@ -1 +1,2 @@
DIST bibtexparser-1.4.0.gh.tar.gz 93130 BLAKE2B e55a5cd960f979af460cca3850e58b035e0a937d2d230b200ea954e1c795ab436d09cdeb4d6b369a7802a9f6d3f98f1533ce821f3df4000a4154103367bb603b SHA512 70fcb501539c25d684ffd84b3a15eb03cf497f70bfdd1d14b2842978e8c6b3d1877d37195789ab3053432582c6c3520f98f90d774835b4c8124505e05905293c
+DIST bibtexparser-1.4.1.gh.tar.gz 97146 BLAKE2B 8040532fe2153ff6ec664631a11b4f61548f99198c565bb554d0fe09d1fa54ee368c08be72bf7e86c5b6ca696deb0210496d4772243a05c5c9b28d73f52e6dc5 SHA512 f8e8f911eac38e98362bbbeff5b4af986e426911db9c54e93ec4a4eee1b1ceed630222c1a51454639566a6b5bad60c86a70b882a1c05084927fcbe7315e837ce
diff --git a/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild b/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
new file mode 100644
index 000000000000..178521806dfa
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-1.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A BibTeX parser written in Python"
+HOMEPAGE="
+ https://github.com/sciunto-org/python-bibtexparser/
+ https://pypi.org/project/bibtexparser/
+"
+SRC_URI="
+ https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="|| ( BSD LGPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest