summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2022-04-04 15:09:21 +0300
committerSergey Popov <pinkbyte@gentoo.org>2022-04-04 15:10:46 +0300
commit41ea1f45ef8603a287ff4723df43dac0103843ce (patch)
treeeec2edd6a51eaacae87cdeb1361df6c953ecd91e
parentsys-apps/uutils: Version bump (diff)
downloadgentoo-41ea1f45ef8603a287ff4723df43dac0103843ce.tar.gz
gentoo-41ea1f45ef8603a287ff4723df43dac0103843ce.tar.bz2
gentoo-41ea1f45ef8603a287ff4723df43dac0103843ce.zip
dev-util/shc-4.0.3: fix tests
Closes: https://bugs.gentoo.org/836761 Reported-by: Agostino Sarubbo <ago@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
-rw-r--r--dev-util/shc/shc-4.0.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/shc/shc-4.0.3.ebuild b/dev-util/shc/shc-4.0.3.ebuild
index 4bc77efcd7a9..818f2d0868eb 100644
--- a/dev-util/shc/shc-4.0.3.ebuild
+++ b/dev-util/shc/shc-4.0.3.ebuild
@@ -11,6 +11,30 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ app-shells/bash:0
+ app-shells/dash
+ app-shells/ksh
+ app-shells/tcsh
+ app-shells/zsh
+)"
+RDEPEND=""
+
+src_prepare() {
+ # ash requires sys-apps/busybox[make-symlinks], so exclude it too
+ # Exclude app-shells/rc from tests
+ # Fix path for app-shells/tcsh
+ sed -i \
+ -e "s:'/bin/ash'::" \
+ -e "s:'/usr/bin/rc'::" \
+ -e "s:/usr/bin/tcsh:/bin/tcsh:" \
+ test/ttest.sh || die
+
+ default
+}
+
src_install() {
dobin src/shc
doman shc.1