summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-17 21:01:26 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-06-15 00:48:29 +0300
commit1c19395c616d44fd34e0999b49aa4060e8c8d602 (patch)
treeaf0f6ac7c7e1fb8ae3263edafd0ff9c4d4ee90a2
parentlxqt-base/lxqt-config: add version 2.0.0 (diff)
downloadgentoo-1c19395c616d44fd34e0999b49aa4060e8c8d602.tar.gz
gentoo-1c19395c616d44fd34e0999b49aa4060e8c8d602.tar.bz2
gentoo-1c19395c616d44fd34e0999b49aa4060e8c8d602.zip
lxqt-base/lxqt-globalkeys: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/lxqt-globalkeys/Manifest1
-rw-r--r--lxqt-base/lxqt-globalkeys/lxqt-globalkeys-2.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-globalkeys/Manifest b/lxqt-base/lxqt-globalkeys/Manifest
index 395b27e6b039..563ea9b3fffa 100644
--- a/lxqt-base/lxqt-globalkeys/Manifest
+++ b/lxqt-base/lxqt-globalkeys/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-globalkeys-1.3.0.tar.xz 73844 BLAKE2B 94b28a092a25895bcca39a8eb8626d19ca3c7ebcedc2898a5a2b222bdc1034c6de3ef3c98653acbc26c20e7b8ba51b54b26c1d1ceded674ab740edffabec93bf SHA512 9acdbff95734bc098b312aa906c38766a035041f8f3e58406470716013762a19d7a8f6cc07377dc8921be9aa09647fff2fef69e7c8ed15109dff71cbaf573eb7
DIST lxqt-globalkeys-1.4.0.tar.xz 74028 BLAKE2B 9dae4f3b436468de75ced76f5e9283d26df587f62c99e16d578c3357784aa8effdf7820786bebcb8da206a9fa62951f448ed1e1ee6fba97f8b065793056f4c5c SHA512 de05c15dc6400978093c1f72340214d53200f8e7478ddee47fb7a3124be642f5d27c6bd53801b6a0205985666dcb481a89208b14d54cf2eb3dc36ccae5bdc1f5
+DIST lxqt-globalkeys-2.0.0.tar.xz 74832 BLAKE2B 9a55e666635b54951d97da733b3df403f859db4b0524061fae3852c8e14e368526b6f9243d6059e06186758a0d2ceeac7cad256062b805c8af6ef5b1306cbea3 SHA512 8fa7f6e7db65f3a3b93ff65a8d27a1dfe262526d7ab18f8a2d0dd4b14c9f22c8d80de8e54fb83b2be228d7200d769e144b01ee8ea5ad7b3fc54b204f68224c3e
diff --git a/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-2.0.0.ebuild b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-2.0.0.ebuild
new file mode 100644
index 000000000000..e1319e6fdcd3
--- /dev/null
+++ b/lxqt-base/lxqt-globalkeys/lxqt-globalkeys-2.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Daemon and library for global keyboard shortcuts registration"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ =lxqt-base/liblxqt-${MY_PV}*:=
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}"