summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-02 22:19:04 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-02 22:19:04 +0300
commit1aefaeb489d312c3b2da84569200846ba80f0657 (patch)
treeead9ca5732b809d14589483e3520e39f215b0f34
parentnet-dns/pdns-recursor: remove libressl support (diff)
downloadgentoo-1aefaeb489d312c3b2da84569200846ba80f0657.tar.gz
gentoo-1aefaeb489d312c3b2da84569200846ba80f0657.tar.bz2
gentoo-1aefaeb489d312c3b2da84569200846ba80f0657.zip
net-dns/unbound: remove libressl support
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
-rw-r--r--net-dns/unbound/unbound-1.13.0-r1.ebuild9
-rw-r--r--net-dns/unbound/unbound-1.13.0.ebuild9
-rw-r--r--net-dns/unbound/unbound-1.13.1.ebuild7
3 files changed, 11 insertions, 14 deletions
diff --git a/net-dns/unbound/unbound-1.13.0-r1.ebuild b/net-dns/unbound/unbound-1.13.0-r1.ebuild
index 30b267d44391..473024caee76 100644
--- a/net-dns/unbound/unbound-1.13.0-r1.ebuild
+++ b/net-dns/unbound/unbound-1.13.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -14,7 +14,7 @@ SRC_URI="https://nlnetlabs.nl/downloads/unbound/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0/8" # ABI version of libunbound.so
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86"
-IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 libressl python redis selinux static-libs systemd test threads"
+IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 python redis selinux static-libs systemd test threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -27,15 +27,14 @@ CDEPEND="acct-group/unbound
acct-user/unbound
>=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
>=dev-libs/libevent-2.0.21:0=[${MULTILIB_USEDEP}]
- libressl? ( >=dev-libs/libressl-2.2.4:0[${MULTILIB_USEDEP}] )
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
dnscrypt? ( dev-libs/libsodium[${MULTILIB_USEDEP}] )
dnstap? (
dev-libs/fstrm[${MULTILIB_USEDEP}]
>=dev-libs/protobuf-c-1.0.2-r1[${MULTILIB_USEDEP}]
)
ecdsa? (
- !libressl? ( dev-libs/openssl:0[-bindist] )
+ dev-libs/openssl:0[-bindist]
)
http2? ( net-libs/nghttp2[${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
diff --git a/net-dns/unbound/unbound-1.13.0.ebuild b/net-dns/unbound/unbound-1.13.0.ebuild
index a8e0c81179f1..7719cd597bc3 100644
--- a/net-dns/unbound/unbound-1.13.0.ebuild
+++ b/net-dns/unbound/unbound-1.13.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -14,7 +14,7 @@ SRC_URI="https://nlnetlabs.nl/downloads/unbound/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0/8" # ABI version of libunbound.so
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~mips ppc ppc64 x86"
-IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 libressl python redis selinux static-libs systemd test threads"
+IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 python redis selinux static-libs systemd test threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -27,15 +27,14 @@ CDEPEND="acct-group/unbound
acct-user/unbound
>=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
>=dev-libs/libevent-2.0.21:0=[${MULTILIB_USEDEP}]
- libressl? ( >=dev-libs/libressl-2.2.4:0[${MULTILIB_USEDEP}] )
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
dnscrypt? ( dev-libs/libsodium[${MULTILIB_USEDEP}] )
dnstap? (
dev-libs/fstrm[${MULTILIB_USEDEP}]
>=dev-libs/protobuf-c-1.0.2-r1[${MULTILIB_USEDEP}]
)
ecdsa? (
- !libressl? ( dev-libs/openssl:0[-bindist] )
+ dev-libs/openssl:0[-bindist]
)
http2? ( net-libs/nghttp2[${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )
diff --git a/net-dns/unbound/unbound-1.13.1.ebuild b/net-dns/unbound/unbound-1.13.1.ebuild
index 094e98544292..473024caee76 100644
--- a/net-dns/unbound/unbound-1.13.1.ebuild
+++ b/net-dns/unbound/unbound-1.13.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://nlnetlabs.nl/downloads/unbound/${MY_P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0/8" # ABI version of libunbound.so
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86"
-IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 libressl python redis selinux static-libs systemd test threads"
+IUSE="debug dnscrypt dnstap +ecdsa ecs gost +http2 python redis selinux static-libs systemd test threads"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RESTRICT="!test? ( test )"
@@ -27,15 +27,14 @@ CDEPEND="acct-group/unbound
acct-user/unbound
>=dev-libs/expat-2.1.0-r3[${MULTILIB_USEDEP}]
>=dev-libs/libevent-2.0.21:0=[${MULTILIB_USEDEP}]
- libressl? ( >=dev-libs/libressl-2.2.4:0[${MULTILIB_USEDEP}] )
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
dnscrypt? ( dev-libs/libsodium[${MULTILIB_USEDEP}] )
dnstap? (
dev-libs/fstrm[${MULTILIB_USEDEP}]
>=dev-libs/protobuf-c-1.0.2-r1[${MULTILIB_USEDEP}]
)
ecdsa? (
- !libressl? ( dev-libs/openssl:0[-bindist] )
+ dev-libs/openssl:0[-bindist]
)
http2? ( net-libs/nghttp2[${MULTILIB_USEDEP}] )
python? ( ${PYTHON_DEPS} )