aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/hare/files/hare-0.24.0-riscv64-comment-syntax.patch25
-rw-r--r--dev-lang/hare/hare-0.24.0.ebuild4
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-lang/hare/files/hare-0.24.0-riscv64-comment-syntax.patch b/dev-lang/hare/files/hare-0.24.0-riscv64-comment-syntax.patch
new file mode 100644
index 000000000..805caf362
--- /dev/null
+++ b/dev-lang/hare/files/hare-0.24.0-riscv64-comment-syntax.patch
@@ -0,0 +1,25 @@
+From 80e45e4d931a6e90d999846b86471cac00d2a6d5 Mon Sep 17 00:00:00 2001
+From: Andreas Schwab <schwab@suse.de>
+Date: Wed, 21 Feb 2024 22:05:02 +0100
+Subject: [PATCH] debug+riscv: use correct comment syntax
+
+Signed-off-by: Andreas Schwab <schwab@suse.de>
+---
+ debug/+riscv64/getfp.s | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/debug/+riscv64/getfp.s b/debug/+riscv64/getfp.s
+index 9c3698af..b822036a 100644
+--- a/debug/+riscv64/getfp.s
++++ b/debug/+riscv64/getfp.s
+@@ -1,5 +1,5 @@
+-// SPDX-License-Identifier: MPL-2.0
+-// (c) Hare authors <https://harelang.org>
++# SPDX-License-Identifier: MPL-2.0
++# (c) Hare authors <https://harelang.org>
+
+ .section ".text.debug.getfp","ax"
+ .global debug.getfp
+--
+2.38.5
+
diff --git a/dev-lang/hare/hare-0.24.0.ebuild b/dev-lang/hare/hare-0.24.0.ebuild
index 380305ec5..0c7db8984 100644
--- a/dev-lang/hare/hare-0.24.0.ebuild
+++ b/dev-lang/hare/hare-0.24.0.ebuild
@@ -31,6 +31,10 @@ RDEPEND="${DEPEND}"
# hare and haredoc are built by hare
QA_FLAGS_IGNORED="usr/bin/hare usr/bin/haredoc"
+PATCHES=(
+ "${FILESDIR}/hare-0.24.0-riscv64-comment-syntax.patch"
+)
+
src_configure() {
local target_arch
case ${ARCH} in