aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2024-03-10 23:05:45 +0100
committerHenri Gasc <gasc@eurecom.fr>2024-03-11 09:42:05 +0100
commit82c23f0653c213f945bfb6eae6316f24401e3c6e (patch)
treefe788585405f2121a40d785e977b0095295078dc /media-video
parentapp-crypt/lego: add 4.16.1 (diff)
downloadguru-82c23f0653c213f945bfb6eae6316f24401e3c6e.tar.gz
guru-82c23f0653c213f945bfb6eae6316f24401e3c6e.tar.bz2
guru-82c23f0653c213f945bfb6eae6316f24401e3c6e.zip
media-video/manimgl: add 9999, drop 1.6.1
Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/manimgl/Manifest1
-rw-r--r--media-video/manimgl/manimgl-9999.ebuild (renamed from media-video/manimgl/manimgl-1.6.1.ebuild)20
2 files changed, 11 insertions, 10 deletions
diff --git a/media-video/manimgl/Manifest b/media-video/manimgl/Manifest
deleted file mode 100644
index 469a5da8d..000000000
--- a/media-video/manimgl/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST manimgl-1.6.1.gh.tar.gz 1043281 BLAKE2B 70c0d4b893e1b15b536fd98e0584d2e5676802e2165407ed0cd62878120ce7f3ff43bf7eec8e16c12c95494322118215689f4138ff9dc190c86be206aa57124c SHA512 30f0675551474c690ee5dc1c9200db6aad114b0ffb14a6245f7d8edb00db9a375e291448df10a8b603527aaafba8930a445e825dd3ee3293dc125f3cfd46fee3
diff --git a/media-video/manimgl/manimgl-1.6.1.ebuild b/media-video/manimgl/manimgl-9999.ebuild
index 69c3bc7b5..dfc646d1e 100644
--- a/media-video/manimgl/manimgl-1.6.1.ebuild
+++ b/media-video/manimgl/manimgl-9999.ebuild
@@ -1,27 +1,30 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1
+inherit distutils-r1 git-r3
DESCRIPTION="Animation engine for explanatory math videos"
HOMEPAGE="https://github.com/3b1b/manim https://pypi.org/project/manimgl/"
-SRC_URI="https://github.com/3b1b/manim/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/manim-${PV}"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/3b1b/manim.git"
+else
+ SRC_URI="https://github.com/3b1b/manim/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/manim-${PV}"
+ KEYWORDS="~amd64"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64"
IUSE="doc"
RDEPEND="
dev-python/colour[${PYTHON_USEDEP}]
- dev-python/fonttools[${PYTHON_USEDEP}]
dev-python/ipython[${PYTHON_USEDEP}]
dev-python/isosurfaces[${PYTHON_USEDEP}]
=dev-python/ManimPango-0.4*[${PYTHON_USEDEP}]
@@ -35,7 +38,6 @@ RDEPEND="
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/pyopengl[${PYTHON_USEDEP}]
dev-python/pyperclip[${PYTHON_USEDEP}]
- dev-python/pyrr[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/rich[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
@@ -46,8 +48,8 @@ RDEPEND="
dev-python/tqdm[${PYTHON_USEDEP}]
dev-python/validators[${PYTHON_USEDEP}]
app-text/texlive
- media-libs/mesa
media-video/ffmpeg
+ virtual/opengl
x11-libs/pango
$(python_gen_cond_dep '
dev-python/typing-extensions[${PYTHON_USEDEP}]