aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucio Sauer <watermanpaint@posteo.net>2023-10-03 01:50:04 +0200
committerLucio Sauer <watermanpaint@posteo.net>2023-10-03 01:54:29 +0200
commit846279ae9cc85f29f30d9e6c08d67fe7ce02320b (patch)
tree4cb3122ce4fd366a5df0bcaa1e22f1678a6464ac /dev-python/types-requests
parentdev-python/grpc-stubs: drop 1.53.0.2 (diff)
downloadguru-846279ae9cc85f29f30d9e6c08d67fe7ce02320b.tar.gz
guru-846279ae9cc85f29f30d9e6c08d67fe7ce02320b.tar.bz2
guru-846279ae9cc85f29f30d9e6c08d67fe7ce02320b.zip
dev-python/types-requests: add 2.31.0.6
Signed-off-by: Lucio Sauer <watermanpaint@posteo.net>
Diffstat (limited to 'dev-python/types-requests')
-rw-r--r--dev-python/types-requests/Manifest1
-rw-r--r--dev-python/types-requests/types-requests-2.31.0.6.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/types-requests/Manifest b/dev-python/types-requests/Manifest
index 91a68b94b..86db47efc 100644
--- a/dev-python/types-requests/Manifest
+++ b/dev-python/types-requests/Manifest
@@ -1 +1,2 @@
DIST types-requests-2.31.0.5.tar.gz 15474 BLAKE2B d1fc25eb9003f47bca74c21d9791aae2830b2242da387e0627e7509a3a52cb417f780fd6c4d5808314000a00b7f0385e1a275d0aaa23e9ecbcfe112290bead7a SHA512 a6df779ddfdc0ad3389d9c5c200bc1b14aefa3d6baf622879789c22230fbd5a3c0a71c0660ddc7abe75a57902abfb356b5c7107136919642d403e6da398c8489
+DIST types-requests-2.31.0.6.tar.gz 15535 BLAKE2B 165bbedb94cf39b271a32c37e58333d0f59b053a3c882c964e5c46f8fe95fba4ce158434714f4352fc426b6c6fcc98e31caf79407d1778c4e514c0a8a6dfe457 SHA512 e35dc869c6192cea6408407fe024c9dcaeac7baa208df250671f0d99d31e36aa20647d3d1823069bdae27b899d1278010ebfc4ad19ef00a922cd1f64636bd521
diff --git a/dev-python/types-requests/types-requests-2.31.0.6.ebuild b/dev-python/types-requests/types-requests-2.31.0.6.ebuild
new file mode 100644
index 000000000..992925ec3
--- /dev/null
+++ b/dev-python/types-requests/types-requests-2.31.0.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Typing stubs for requests"
+HOMEPAGE="
+ https://pypi.org/project/types-requests/
+ https://github.com/python/typeshed/tree/master/stubs/requests
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64"
+
+# Depends on _typeshed util stub module bundled with mypy and other type checkers.
+RDEPEND="dev-python/types-urllib3"