aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-12 03:20:48 +0100
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-03-12 04:03:04 +0100
commitd3b0bbd45164aad4ad4eb7149dd2d9e3c5843bb9 (patch)
tree8d5ded25f1d8ed8d40930b289eef2eba4d17acc2 /dev-python/etcd3gw
parentdev-python/etcd3: add etcd dependency (diff)
downloadguru-d3b0bbd45164aad4ad4eb7149dd2d9e3c5843bb9.tar.gz
guru-d3b0bbd45164aad4ad4eb7149dd2d9e3c5843bb9.tar.bz2
guru-d3b0bbd45164aad4ad4eb7149dd2d9e3c5843bb9.zip
dev-python/etcd3gw: add 1.0.1
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-python/etcd3gw')
-rw-r--r--dev-python/etcd3gw/Manifest1
-rw-r--r--dev-python/etcd3gw/etcd3gw-1.0.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/etcd3gw/Manifest b/dev-python/etcd3gw/Manifest
index 433757e38..03bc566fc 100644
--- a/dev-python/etcd3gw/Manifest
+++ b/dev-python/etcd3gw/Manifest
@@ -1 +1,2 @@
DIST etcd3gw-1.0.0.tar.gz 27035 BLAKE2B 5ad3dfb1b08388f4d73fc9e857d7e7610672cfde8aa0de55eb7bf6a50dd58a937fbabea19c31ebef5a9f7181f96447ad1d381e2724f6a10be589447fcedbaec1 SHA512 d1aac81ebd221277c03bbb0f5dd76bb7c99a52132113959cf397fd44a598ade77300d506e2e5cfa04864cfd6a16f40ea8ddd350a4763a30609d8d922224c78ac
+DIST etcd3gw-1.0.1.tar.gz 27309 BLAKE2B dbc2c4cc76b6602d5d631609fed49dd556c86f763d4d59f14d7d514f0e7fb43ea94e5841883b9eacfa599ec0c7bb09797496017b51b23b362dd3b1bfd42b447e SHA512 d90b69afd64f023cd16e5f9ac31c61e285887db9f364ebcf176dae56b02e4e9f7b05713d358cebde3a3d8769896a768499f99945e34d015a73634251c28b31fe
diff --git a/dev-python/etcd3gw/etcd3gw-1.0.1.ebuild b/dev-python/etcd3gw/etcd3gw-1.0.1.ebuild
new file mode 100644
index 000000000..98ebcc27d
--- /dev/null
+++ b/dev-python/etcd3gw/etcd3gw-1.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python client for etcd3 grpc-gateway v3 API"
+HOMEPAGE="
+ https://opendev.org/openstack/etcd3gw
+ https://pypi.org/project/etcd3gw/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pbr-2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/futurist-0.16.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pifpaf-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.7[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.15.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest