aboutsummaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-29 04:46:45 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-04-29 04:46:45 +0200
commit39820b1b13adf864f4c405951d620af09c00e684 (patch)
tree0fc7e665c4a26f0c2ce610022974ccfccb539f07 /dev-ml
parentdev-ml/alcotest-lwt: add 1.5.0 (diff)
downloadguru-39820b1b13adf864f4c405951d620af09c00e684.tar.gz
guru-39820b1b13adf864f4c405951d620af09c00e684.tar.bz2
guru-39820b1b13adf864f4c405951d620af09c00e684.zip
dev-ml/tls: add 0.15.3
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/tls/Manifest1
-rw-r--r--dev-ml/tls/tls-0.15.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-ml/tls/Manifest b/dev-ml/tls/Manifest
index c5b08613c..9a9e1de53 100644
--- a/dev-ml/tls/Manifest
+++ b/dev-ml/tls/Manifest
@@ -1 +1,2 @@
+DIST tls-0.15.3.tbz 322581 BLAKE2B b516d0b4d950cd2b9c4da69ad6e45aea6b0cbc5af7ce8842261245e8e00f690a4c91e3ad97b900658babdc1493b202487105e32a7b0ce99f4394baadd06abfd9 SHA512 371b85c6afebeda0fcc8cc5252e3333d9c3ef3a6bdbee160bb194e2a5928fd537c811c6eec729f16852070944e627257d44c97142a259d00d0db66956a95df49
DIST tls-v0.13.1.tbz 299082 BLAKE2B e366f0135233c67aac72cb930d9c702ff660bb2eeaa4e2105a695026866d7723a6e41657d3f4d1a107742325d875612183ed51d96d2a9d5da50d358a99688fa3 SHA512 f5ec06a9401c5bba7b9ba011fbec14136685b673f4ec87d0eefedb9cb53f93d02142bb9a75955b8c2c5832cdcebec8751c63ce092d2b6e361a19fe1a8a1e36b1
diff --git a/dev-ml/tls/tls-0.15.3.ebuild b/dev-ml/tls/tls-0.15.3.ebuild
new file mode 100644
index 000000000..cff9e9abd
--- /dev/null
+++ b/dev-ml/tls/tls-0.15.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Transport Layer Security purely in OCaml"
+HOMEPAGE="https://github.com/mirleft/ocaml-tls"
+SRC_URI="https://github.com/mirleft/ocaml-tls/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async mirage ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=dev-ml/ppx_sexp_conv-0.9.0:=
+ >=dev-ml/cstruct-6.0.0:=[ppx,sexp]
+ dev-ml/sexplib:=
+ >=dev-ml/mirage-crypto-0.10.0:=[ec,pk,rng]
+ >=dev-ml/x509-0.13.0:=
+ >=dev-ml/domain-name-0.3.0:=
+ >=dev-ml/fmt-0.8.7:=
+ >=dev-ml/lwt-3.0.0:=
+ >=dev-ml/ptime-0.8.1:=
+ dev-ml/hkdf:=
+ dev-ml/logs:=
+ dev-ml/ipaddr:=[sexp]
+
+ async? (
+ >=dev-ml/async-0.15:=
+ >=dev-ml/async_unix-0.15:=
+ >=dev-ml/core-0.15:=
+ dev-ml/cstruct:=[async]
+ >=dev-ml/ppx_jane-0.15:=
+ dev-ml/mirage-crypto:=[rng-async]
+ >=dev-ml/x509-0.14.0:=
+ )
+ mirage? (
+ >=dev-ml/mirage-flow-2.0.0:=
+ >=dev-ml/mirage-kv-3.0.0:=
+ >=dev-ml/mirage-clock-3.0.0:=
+ dev-ml/mirage-crypto:=[pk]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-ml/cstruct-3.0.0[unix]
+ dev-ml/alcotest
+ dev-ml/randomconv
+ dev-ml/ounit2
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+src_compile() {
+ local pkgs="tls"
+ for u in async mirage ; do
+ if use ${u} ; then
+ pkgs="${pkgs},tls-${u}"
+ fi
+ done
+ dune build -p "${pkgs}" -j $(makeopts_jobs) || die
+}
+
+src_install() {
+ dune_src_install tls
+ use async && dune_src_install tls-async
+ use mirage && dune_src_install tls-mirage
+}