aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-01-29 08:24:50 +0100
committerHaelwenn (lanodan) Monnier <contact@hacktivis.me>2023-01-29 11:51:49 +0100
commit794862ec39d9cadbf509f29b16e403413e276708 (patch)
treea00a15d94a98f027b2a5fa981e5f49a7273b9189 /dev-games
parentdev-util/typescript-language-server: fix src_unpack (diff)
downloadguru-794862ec39d9cadbf509f29b16e403413e276708.tar.gz
guru-794862ec39d9cadbf509f29b16e403413e276708.tar.bz2
guru-794862ec39d9cadbf509f29b16e403413e276708.zip
dev-games/liblcf: new package, add 0.7.0
Signed-off-by: Haelwenn (lanodan) Monnier <contact@hacktivis.me>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/liblcf/Manifest1
-rw-r--r--dev-games/liblcf/liblcf-0.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-games/liblcf/Manifest b/dev-games/liblcf/Manifest
new file mode 100644
index 000000000..927fc9188
--- /dev/null
+++ b/dev-games/liblcf/Manifest
@@ -0,0 +1 @@
+DIST liblcf-0.7.0.tar.gz 292623 BLAKE2B 7cf2f21244796b85745ac30bcc3ec7118dd10d5a7054fdd423bbb71ab9b0a4c85ccc644bd57c251374378fe525e1302367456ee348828efb8d97d825727f2caa SHA512 0abf77a7e4615f21b643b0e35d41450dc0dbd37d337fbbf619a19f73da3ee18e9d216f151f52a121be2d91bfee47c1a153f4c64df630d5c587cf4b6071e5b77a
diff --git a/dev-games/liblcf/liblcf-0.7.0.ebuild b/dev-games/liblcf/liblcf-0.7.0.ebuild
new file mode 100644
index 000000000..aa0cbea45
--- /dev/null
+++ b/dev-games/liblcf/liblcf-0.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Library to handle RPG Maker 2000/2003 and EasyRPG projects"
+HOMEPAGE="https://github.com/EasyRPG/liblcf"
+SRC_URI="https://github.com/EasyRPG/liblcf/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/icu:=
+ doc? ( app-doc/doxygen )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=True
+ -DLIBLCF_UPDATE_MIMEDB=False
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_build check
+}
+
+pkg_postrm() { xdg_mimeinfo_database_update; }
+pkg_postinst() { xdg_mimeinfo_database_update; }