summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/notion/ChangeLog10
-rw-r--r--x11-wm/notion/Manifest15
-rw-r--r--x11-wm/notion/files/notion2
-rw-r--r--x11-wm/notion/files/notion.desktop9
-rw-r--r--x11-wm/notion/metadata.xml16
-rw-r--r--x11-wm/notion/notion-9999.ebuild74
6 files changed, 126 insertions, 0 deletions
diff --git a/x11-wm/notion/ChangeLog b/x11-wm/notion/ChangeLog
new file mode 100644
index 000000000000..8e627f88640a
--- /dev/null
+++ b/x11-wm/notion/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-wm/notion
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/ChangeLog,v 1.1 2012/06/20 18:52:51 xmw Exp $
+
+*notion-9999 (20 Jun 2012)
+
+ 20 Jun 2012; Michael Weber <xmw@gentoo.org> +notion-9999.ebuild,
+ +files/notion, +files/notion.desktop, +metadata.xml:
+ Initial import based on Hobbits work (bug 422481)
+
diff --git a/x11-wm/notion/Manifest b/x11-wm/notion/Manifest
new file mode 100644
index 000000000000..30e12dee9965
--- /dev/null
+++ b/x11-wm/notion/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+AUX notion 26 RMD160 1f8bcf9b6f3bb95de7dba24b5a027229be309422 SHA1 465c3c47149133067b1b03741d611f94b7a9dea7 SHA256 70ff05ede1d85ff4bf8d5100aa7ace3bb89ac09596543c6829fb1f65fddb546c
+AUX notion.desktop 223 RMD160 71ac6451675586c6fc9c8213893684e71dbcc9d1 SHA1 d1b4cc5a5d644dbeff891afff32d2e7855d6c37c SHA256 4581319c329385f0bc5c18fe0037a4820ab1650a3af7ffe403a87e7fe5bf0987
+EBUILD notion-9999.ebuild 1996 RMD160 8e2158b5da00e85b5d7b9722ec5192b90873307f SHA1 09ae17ce767c12f100333e7271002413469749b7 SHA256 19367902cb0da4ec61b1a820144f5dcec50c59fa1a11bb1b4021f206013e2c83
+MISC ChangeLog 399 RMD160 d76bbfadbbc8fbd9d44d4356d221ef7cbfcfee99 SHA1 eaf7e819804dbc012cc5a6a08d2230f956f75262 SHA256 ce7023fbf507e42777447d29f73f611b25bdddf54269921cd1a604ebfd3755b7
+MISC metadata.xml 434 RMD160 99e646d4f23f32a60d340a928775267e58bbb174 SHA1 5086b5d722e2f7236b3fa97834c3b04c5fccaf18 SHA256 32b95389735b11aedde8ebee47b81131b101922e926c8eface1b4f70057f53c9
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk/iG98ACgkQknrdDGLu8JAOTAD+KNo4lEZG/agmrrAHx3QJtVi3
+d1B5sUgBwvhdGUHpaXQBAI9dZ7KUR+AN0lWu1h9M7I7sKdkv12YxRU1o2jfsUmqc
+=k6zo
+-----END PGP SIGNATURE-----
diff --git a/x11-wm/notion/files/notion b/x11-wm/notion/files/notion
new file mode 100644
index 000000000000..65bf5648ad0b
--- /dev/null
+++ b/x11-wm/notion/files/notion
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/notion
diff --git a/x11-wm/notion/files/notion.desktop b/x11-wm/notion/files/notion.desktop
new file mode 100644
index 000000000000..b849e69ef27d
--- /dev/null
+++ b/x11-wm/notion/files/notion.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Notion
+Comment=A tiling tabbed window manager designed with keyboard users in mind.
+Exec=notion
+TryExec=notion
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application
diff --git a/x11-wm/notion/metadata.xml b/x11-wm/notion/metadata.xml
new file mode 100644
index 000000000000..5b72bd06f9c2
--- /dev/null
+++ b/x11-wm/notion/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>little_hobbit@lavabit.com</email>
+</maintainer>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ <description>Proxy maintainer</description>
+</maintainer>
+<use>
+ <flag name="xrandr">Add support for xrandr</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-wm/notion/notion-9999.ebuild b/x11-wm/notion/notion-9999.ebuild
new file mode 100644
index 000000000000..ef4df1f6d8a4
--- /dev/null
+++ b/x11-wm/notion/notion-9999.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/notion/notion-9999.ebuild,v 1.1 2012/06/20 18:52:51 xmw Exp $
+
+EAPI="4"
+
+EGIT_REPO_URI="git://notion.git.sourceforge.net/gitroot/notion/notion"
+EGIT_HAS_SUBMODULES="1"
+
+inherit eutils git-2 toolchain-funcs
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="http://notion.sourceforge.net"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls xinerama +xrandr"
+
+RDEPEND="dev-lang/lua
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -e "/^CFLAGS=/s:=:+=:" \
+ -e "/^CFLAGS/{s:-Os:: ; s:-g::}" \
+ -e "/^LDFLAGS=/{s:=:+=: ; s:-Wl,--as-needed::}" \
+ -e "/^CC=/s:=:?=:" \
+ -e "s:^\(PREFIX=\).*$:\1${ROOT}usr:" \
+ -e "s:^\(ETCDIR=\).*$:\1${ROOT}etc/notion:" \
+ -e "s:^\(LIBDIR=\).*:\1\$(PREFIX)/$(get_libdir):" \
+ -e "s:^\(DOCDIR=\).*:\1\$(PREFIX)/share/doc/${PF}:" \
+ -e "s:^\(LUA_DIR=\).*$:\1\$(PREFIX)/usr:" \
+ -e "s:^\(VARDIR=\).*$:\1${ROOT}var/cache/${PN}:" \
+ -e "s:^\(X11_PREFIX=\).*:\1\$(PREFIX)/usr:" \
+ -i system.mk || die
+ sed -e "/_install:/,+3s:\(\$(BINDIR)\):\$(DESTDIR)\1:" \
+ -i mod_notionflux/notionflux/Makefile || die
+ export STRIPPROG=cat
+
+ use nls || export DEFINES=" -DCF_NO_LOCALE -DCF_NO_GETTEXT"
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ fi
+
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+}
+
+pkg_postinst() {
+ elog "If you want notion to have an ability to view a file based on its"
+ elog "guessed MIME type you need 'run-mailcap' program in your system."
+}