summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/talloc/talloc-2.1.0.ebuild')
-rw-r--r--sys-libs/talloc/talloc-2.1.0.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/sys-libs/talloc/talloc-2.1.0.ebuild b/sys-libs/talloc/talloc-2.1.0.ebuild
index d9707129656c..2932ee9f4f48 100644
--- a/sys-libs/talloc/talloc-2.1.0.ebuild
+++ b/sys-libs/talloc/talloc-2.1.0.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.1.0.ebuild,v 1.3 2014/02/01 20:50:03 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.1.0.ebuild,v 1.4 2014/02/02 17:40:57 vostorga Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
PYTHON_REQ_USE="threads"
-inherit waf-utils python-single-r1 multilib multilib-minimal
+inherit waf-utils python-single-r1 multilib
DESCRIPTION="Samba talloc library"
HOMEPAGE="http://talloc.samba.org/"
@@ -21,7 +21,6 @@ IUSE="compat +python"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r5 )
!!<sys-libs/talloc-2.0.5"
DEPEND="${RDEPEND}
dev-libs/libxslt
@@ -29,11 +28,7 @@ DEPEND="${RDEPEND}
WAF_BINARY="${S}/buildtools/bin/waf"
-src_prepare() {
- multilib_copy_sources
-}
-
-multilib_src_configure() {
+src_configure() {
local extra_opts=""
use compat && extra_opts+=" --enable-talloc-compat1"
@@ -42,7 +37,7 @@ multilib_src_configure() {
${extra_opts}
}
-multilib_src_install() {
+src_install() {
waf-utils_src_install
# waf is stupid, and no, we can't fix the build-system, since it's provided