summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog6
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r1.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 20f334f74191..caed79b57786 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,12 +1,14 @@
# ChangeLog for sys-apps/busybox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.9 2003/01/13 07:54:53 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.10 2003/01/13 08:37:36 raker Exp $
*busybox-0.60.5-r1 (13 Jan 2003)
13 Jan 2003; Nick Hadaway <raker@gentoo.org> busybox-0.60.5-r1.ebuild :
Added some logic for detection of uclibc which needs to be tested.
- Please comment on bug #13517.
+ Please comment on bug #13517. 2 hours later: New local environment
+ variable $LINK_LIBC. Set to "uclibc" to link against uclibc instead
+ of glibc.
*busybox-0.60.5 (20 Dec 2002)
diff --git a/sys-apps/busybox/busybox-0.60.5-r1.ebuild b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
index b32f00fdb5b5..b87196f79ffd 100644
--- a/sys-apps/busybox/busybox-0.60.5-r1.ebuild
+++ b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.1 2003/01/13 07:54:53 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.2 2003/01/13 08:37:36 raker Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Utilities for rescue and embedded systems"
@@ -25,9 +25,7 @@ src_unpack() {
src_compile() {
local myconf
use static && myconf="${myconf} DOSTATIC=true"
- INSTLIBC="`best_version virtual/glibc`"
- UCLIBC="dev-libs/uclibc"
- if [ ${INSTLIBC:0:${#UCLIBC}} = $UCLIBC ]; then
+ if [ "$LINK_LIBC" = "uclibc" ]; then
myconf="${myconf} \
CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
USE_SYSTEM_PWD=false"