summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/pmacct/pmacct-0.9.4.ebuild')
-rw-r--r--net-analyzer/pmacct/pmacct-0.9.4.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/net-analyzer/pmacct/pmacct-0.9.4.ebuild b/net-analyzer/pmacct/pmacct-0.9.4.ebuild
new file mode 100644
index 000000000000..ad4dc2956076
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.9.4.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.9.4.ebuild,v 1.1 2005/11/08 13:49:55 vanquirius Exp $
+
+MY_P="${P%_*}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.ba.cnr.it/~paolo/pmacct/"
+SRC_URI="http://www.ba.cnr.it/~paolo/pmacct/${P/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="64bit debug ipv6 mmap mysql postgres"
+
+RDEPEND="virtual/libpcap
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable 64bit) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd ${FILESDIR}/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd ${FILESDIR}/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins ${S}/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}