summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Log')
-rw-r--r--dev-php/PEAR-Log/ChangeLog7
-rw-r--r--dev-php/PEAR-Log/PEAR-Log-1.12.5.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-php/PEAR-Log/ChangeLog b/dev-php/PEAR-Log/ChangeLog
index 20e15e64b90c..970080e7d740 100644
--- a/dev-php/PEAR-Log/ChangeLog
+++ b/dev-php/PEAR-Log/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/PEAR-Log
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/ChangeLog,v 1.85 2010/02/16 04:46:33 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/ChangeLog,v 1.86 2010/12/27 13:46:12 olemarkus Exp $
+
+*PEAR-Log-1.12.5 (27 Dec 2010)
+
+ 27 Dec 2010; <olemarkus@gentoo.org> +PEAR-Log-1.12.5.ebuild:
+ Version bump
*PEAR-Log-1.12.0 (16 Feb 2010)
diff --git a/dev-php/PEAR-Log/PEAR-Log-1.12.5.ebuild b/dev-php/PEAR-Log/PEAR-Log-1.12.5.ebuild
new file mode 100644
index 000000000000..4c4b3882e2cb
--- /dev/null
+++ b/dev-php/PEAR-Log/PEAR-Log-1.12.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-Log/PEAR-Log-1.12.5.ebuild,v 1.1 2010/12/27 13:46:12 olemarkus Exp $
+
+EAPI="2"
+inherit php-pear-r1 depend.php eutils
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DESCRIPTION="The Log framework provides an abstracted logging system.@"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE="minimal"
+
+RDEPEND="!minimal? ( >=dev-php/PEAR-DB-1.7.6-r1
+ dev-php/PEAR-Mail
+ >=dev-php/PEAR-MDB2-2.0.0_rc1 )"
+
+pkg_postinst() {
+ has_php
+ if ! use minimal && ! has_version =${PHP_PKG}[sqlite] ; then
+ elog "${PN} can optionally use ${PHP_PKG} sqlite features."
+ elog "If you want those, recompile ${PHP_PKG} with this flag in USE."
+ fi
+}