summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Net-DNS/Net-DNS-0.660.0-r1.ebuild')
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.660.0-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-perl/Net-DNS/Net-DNS-0.660.0-r1.ebuild b/dev-perl/Net-DNS/Net-DNS-0.660.0-r1.ebuild
new file mode 100644
index 000000000000..82ef1cafdd50
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-0.660.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.660.0-r1.ebuild,v 1.1 2014/08/23 02:19:57 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=OLAF
+MODULE_VERSION=0.66
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6 test"
+
+RDEPEND="virtual/perl-Digest-MD5
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-SHA
+ dev-perl/Net-IP
+ ipv6? ( dev-perl/IO-Socket-INET6 )
+ virtual/perl-MIME-Base64"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ )"
+
+PATCHES=( ${FILESDIR}/${PN}-0.64-ar.patch )
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ if use ipv6 ; then
+ myconf="--IPv6-tests"
+ else
+ myconf="--no-IPv6-tests"
+ fi
+ myconf="${myconf} --no-online-tests"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}