summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libcroco/libcroco-0.6.2.ebuild')
-rw-r--r--dev-libs/libcroco/libcroco-0.6.2.ebuild20
1 files changed, 16 insertions, 4 deletions
diff --git a/dev-libs/libcroco/libcroco-0.6.2.ebuild b/dev-libs/libcroco/libcroco-0.6.2.ebuild
index d5d2b3372586..11d74f49b22d 100644
--- a/dev-libs/libcroco/libcroco-0.6.2.ebuild
+++ b/dev-libs/libcroco/libcroco-0.6.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcroco/libcroco-0.6.2.ebuild,v 1.11 2010/10/07 22:22:57 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcroco/libcroco-0.6.2.ebuild,v 1.12 2011/01/27 11:28:49 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
-EAPI=2
inherit gnome2
DESCRIPTION="Generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
@@ -11,7 +13,7 @@ HOMEPAGE="http://www.freespiders.org/projects/libcroco/"
LICENSE="LGPL-2"
SLOT="0.6"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="doc"
+IUSE="doc test"
RDEPEND="dev-libs/glib:2
>=dev-libs/libxml2-2.4.23"
@@ -23,3 +25,13 @@ pkg_setup() {
G2CONF="${G2CONF} --disable-static"
DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ # don't waste time building tests
+ sed 's/^\(SUBDIRS .*\=.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+}