summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hashtables/hashtables-1.0.1.2.ebuild')
-rw-r--r--dev-haskell/hashtables/hashtables-1.0.1.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-haskell/hashtables/hashtables-1.0.1.2.ebuild b/dev-haskell/hashtables/hashtables-1.0.1.2.ebuild
new file mode 100644
index 000000000000..d7b6909e7dd4
--- /dev/null
+++ b/dev-haskell/hashtables/hashtables-1.0.1.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/hashtables-1.0.1.2.ebuild,v 1.1 2012/01/23 10:04:37 gienah Exp $
+
+# ebuild generated by hackport 0.2.14
+
+EAPI="3"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Mutable hash tables in the ST monad"
+HOMEPAGE="http://github.com/gregorycollins/hashtables"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="<dev-haskell/hashable-2
+ dev-haskell/primitive
+ >=dev-haskell/vector-0.7
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"