summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-crypto/go-crypto-9999.ebuild')
-rw-r--r--dev-go/go-crypto/go-crypto-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-go/go-crypto/go-crypto-9999.ebuild b/dev-go/go-crypto/go-crypto-9999.ebuild
new file mode 100644
index 000000000000..1ce635086f5e
--- /dev/null
+++ b/dev-go/go-crypto/go-crypto-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-crypto/go-crypto-9999.ebuild,v 1.1 2015/05/19 05:21:21 zmedico Exp $
+
+EAPI=5
+inherit git-r3
+
+KEYWORDS=""
+DESCRIPTION="Go supplementary cryptography libraries"
+GO_PN=golang.org/x/${PN##*-}
+HOMEPAGE="https://godoc.org/${GO_PN}"
+EGIT_REPO_URI="https://go.googlesource.com/${PN##*-}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4"
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+EGIT_CHECKOUT_DIR="${S}"
+STRIP_MASK="*.a"
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ GOROOT="${WORKDIR}/goroot"
+ cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN%/*}" \
+ "${GOROOT}/pkg/linux_${ARCH}/${GO_PN%/*}" || die
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
+}
+
+src_install() {
+ insinto /usr/lib/go
+ find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ doins -r "${WORKDIR}"/{pkg,src}
+}