summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/pdksh/pdksh-5.2.14-r3.ebuild')
-rw-r--r--app-shells/pdksh/pdksh-5.2.14-r3.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-shells/pdksh/pdksh-5.2.14-r3.ebuild b/app-shells/pdksh/pdksh-5.2.14-r3.ebuild
index 8966a8c48864..922ed5d0691a 100644
--- a/app-shells/pdksh/pdksh-5.2.14-r3.ebuild
+++ b/app-shells/pdksh/pdksh-5.2.14-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r3.ebuild,v 1.4 2002/07/25 15:39:00 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/pdksh/pdksh-5.2.14-r3.ebuild,v 1.5 2002/07/25 15:44:04 aliz Exp $
S=${WORKDIR}/${P}
DESCRIPTION="The Public Domain Korn Shell"
@@ -12,17 +12,18 @@ SLOT="0"
LICENSE="as-is"
DEPEND=">=sys-libs/glibc-2.1.3"
+RDEPEND=$DEPEND
src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
- patch -p2 < ${DISTDIR}/${P}-patches.1
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch -p2 < ${DISTDIR}/${P}-patches.1
}
src_compile() {
- try ./configure --prefix=/usr --host=${CHOST}
- try make
+ ./configure --prefix=/usr --host=${CHOST} || die
+ make || die
}
src_install() {