summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office')
-rw-r--r--app-office/karbon/ChangeLog7
-rw-r--r--app-office/karbon/karbon-2.0.2.ebuild36
-rw-r--r--app-office/kchart/ChangeLog7
-rw-r--r--app-office/kchart/kchart-2.0.2.ebuild29
-rw-r--r--app-office/koffice-data/ChangeLog8
-rw-r--r--app-office/koffice-data/koffice-data-2.0.2.ebuild24
-rw-r--r--app-office/koffice-l10n/ChangeLog8
-rw-r--r--app-office/koffice-l10n/koffice-l10n-2.0.2.ebuild73
-rw-r--r--app-office/koffice-libs/ChangeLog8
-rw-r--r--app-office/koffice-libs/koffice-libs-2.0.2.ebuild70
-rw-r--r--app-office/koffice-meta/ChangeLog8
-rw-r--r--app-office/koffice-meta/koffice-meta-2.0.2.ebuild26
-rw-r--r--app-office/kplato/ChangeLog7
-rw-r--r--app-office/kplato/kplato-2.0.2.ebuild19
-rw-r--r--app-office/kpresenter/ChangeLog8
-rw-r--r--app-office/kpresenter/kpresenter-2.0.2.ebuild22
-rw-r--r--app-office/krita/ChangeLog7
-rw-r--r--app-office/krita/krita-2.0.2.ebuild51
-rw-r--r--app-office/kspread/ChangeLog8
-rw-r--r--app-office/kspread/kspread-2.0.2.ebuild38
-rw-r--r--app-office/kword/ChangeLog7
-rw-r--r--app-office/kword/kword-2.0.2.ebuild39
22 files changed, 499 insertions, 11 deletions
diff --git a/app-office/karbon/ChangeLog b/app-office/karbon/ChangeLog
index 8721657b77ae..7d52ab254db7 100644
--- a/app-office/karbon/ChangeLog
+++ b/app-office/karbon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/karbon
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.94 2009/07/23 14:02:58 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/ChangeLog,v 1.95 2009/08/12 10:00:58 scarabeus Exp $
+
+*karbon-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> +karbon-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
karbon-1.6.3_p20090204.ebuild:
diff --git a/app-office/karbon/karbon-2.0.2.ebuild b/app-office/karbon/karbon-2.0.2.ebuild
new file mode 100644
index 000000000000..fbf243c39bff
--- /dev/null
+++ b/app-office/karbon/karbon-2.0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/karbon/karbon-2.0.2.ebuild,v 1.1 2009/08/12 10:00:58 scarabeus Exp $
+
+EAPI="2"
+KMNAME="koffice"
+KMMODULE="${PN}"
+
+inherit kde4-meta
+
+DESCRIPTION="KOffice vector drawing application."
+
+KEYWORDS="~amd64 ~x86"
+IUSE="+pstoedit +wpg"
+
+DEPEND="
+ media-libs/libart_lgpl
+ pstoedit? ( media-gfx/pstoedit )
+ wpg? ( media-libs/libwpg )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}"
+KMEXTRACTONLY="
+ libs/
+ plugins/
+ filters/
+"
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with wpg WPG)
+ $(cmake-utils_use_with pstoedit Pstoedit)"
+ kde4-meta_src_configure
+}
diff --git a/app-office/kchart/ChangeLog b/app-office/kchart/ChangeLog
index 4b8ce55f432f..3312bb741452 100644
--- a/app-office/kchart/ChangeLog
+++ b/app-office/kchart/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kchart
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/ChangeLog,v 1.93 2009/07/23 14:03:45 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/ChangeLog,v 1.94 2009/08/12 10:02:53 scarabeus Exp $
+
+*kchart-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> +kchart-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
kchart-1.6.3_p20090204.ebuild:
diff --git a/app-office/kchart/kchart-2.0.2.ebuild b/app-office/kchart/kchart-2.0.2.ebuild
new file mode 100644
index 000000000000..f7757be36b2e
--- /dev/null
+++ b/app-office/kchart/kchart-2.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kchart/kchart-2.0.2.ebuild,v 1.1 2009/08/12 10:02:53 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice chart application."
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ libs/
+ interfaces/
+ filters/
+ plugins/
+"
+KMEXTRA="
+ filters/${KMMODULE}/
+"
+
+KMLOADLIBS="koffice-libs"
diff --git a/app-office/koffice-data/ChangeLog b/app-office/koffice-data/ChangeLog
index 362e485883a9..2d39b65c65b5 100644
--- a/app-office/koffice-data/ChangeLog
+++ b/app-office/koffice-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-data
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-data/ChangeLog,v 1.87 2009/07/23 14:01:23 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-data/ChangeLog,v 1.88 2009/08/12 10:02:04 scarabeus Exp $
+
+*koffice-data-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +koffice-data-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
koffice-data-1.6.3_p20090204.ebuild:
diff --git a/app-office/koffice-data/koffice-data-2.0.2.ebuild b/app-office/koffice-data/koffice-data-2.0.2.ebuild
new file mode 100644
index 000000000000..9661bef1b429
--- /dev/null
+++ b/app-office/koffice-data/koffice-data-2.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-data/koffice-data-2.0.2.ebuild,v 1.1 2009/08/12 10:02:04 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Shared KOffice data files."
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/lcms-1.18"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="pics/
+ servicetypes/
+ templates/"
+KMEXTRACTONLY="
+ doc/CMakeLists.txt
+ doc/koffice.desktop"
diff --git a/app-office/koffice-l10n/ChangeLog b/app-office/koffice-l10n/ChangeLog
index e04c0b92b48c..a126b8c2d63b 100644
--- a/app-office/koffice-l10n/ChangeLog
+++ b/app-office/koffice-l10n/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-l10n
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.4 2009/06/25 12:35:27 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/ChangeLog,v 1.5 2009/08/12 10:04:46 scarabeus Exp $
+
+*koffice-l10n-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +koffice-l10n-2.0.2.ebuild:
+ Version bump to 2.0.2.
*koffice-l10n-2.0.1 (25 Jun 2009)
diff --git a/app-office/koffice-l10n/koffice-l10n-2.0.2.ebuild b/app-office/koffice-l10n/koffice-l10n-2.0.2.ebuild
new file mode 100644
index 000000000000..c3a4a70b0e39
--- /dev/null
+++ b/app-office/koffice-l10n/koffice-l10n-2.0.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-l10n/koffice-l10n-2.0.2.ebuild,v 1.1 2009/08/12 10:04:46 scarabeus Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+MY_LANGS="ca cs da de el en_GB es et fr fy gl hi it ja kk nb nds nl pl pt pt_BR sv tr
+ uk wa zh_CN zh_TW"
+URI_BASE="mirror://kde/stable/koffice-${PV}/src/${PN}/"
+SRC_URI=""
+SLOT="2"
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local lng dir
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for lng in ${MY_LANGS}; do
+ dir="${PN}-${lng}-${PV}"
+ if [[ -d "${dir}" ]] ; then
+ echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs="${mycmakeargs} -DBUILD_MESSAGES=ON -DBUILD_DATA=ON
+ $(cmake-utils_use_build doc)"
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -e "${S}"/CMakeLists.txt ]] && kde4-base_src_install
+}
diff --git a/app-office/koffice-libs/ChangeLog b/app-office/koffice-libs/ChangeLog
index f72b2c430fa0..85cfd1f74cfa 100644
--- a/app-office/koffice-libs/ChangeLog
+++ b/app-office/koffice-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-libs
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.95 2009/07/23 14:02:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/ChangeLog,v 1.96 2009/08/12 09:59:38 scarabeus Exp $
+
+*koffice-libs-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +koffice-libs-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
koffice-libs-1.6.3_p20090204.ebuild:
diff --git a/app-office/koffice-libs/koffice-libs-2.0.2.ebuild b/app-office/koffice-libs/koffice-libs-2.0.2.ebuild
new file mode 100644
index 000000000000..a0f998505dcc
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-2.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-2.0.2.ebuild,v 1.1 2009/08/12 09:59:38 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="libs"
+OPENGL_REQUIRED="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Shared KOffice libraries."
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt +openexr"
+
+RDEPEND="
+ >=app-office/koffice-data-${PV}:${SLOT}
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ >=media-libs/lcms-1.15
+ >=x11-libs/qt-gui-4.5
+ crypt? ( app-crypt/qca:2 )
+ openexr? ( media-libs/openexr )
+ opengl? ( media-libs/mesa )
+"
+DEPEND="${RDEPEND}"
+# doc? ( app-doc/doxygen )"
+
+KMEXTRA="
+ doc/koffice/
+ doc/thesaurus/
+ filters/generic_wrapper/
+ filters/libkowmf/
+ filters/xsltfilter/
+ interfaces/
+ kounavail/
+ plugins/
+ tools/"
+# doc/api/"
+KMEXTRACTONLY="
+ doc/koffice.desktop"
+
+KMSAVELIBS="true"
+
+src_prepare() {
+ sed -i \
+ -e "s:QtCrypto/QtCrypto:QtCrypto:" \
+ libs/store/KoEncryptedStore.h || die
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with openexr OpenEXR)"
+ use crypt && mycmakeargs="${mycmakeargs}
+ -DQCA2_LIBRARIES=/usr/$(get_libdir)/qca2/libqca.so.2"
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ newdoc kounavail/README README.kounavail
+
+ kde4-meta_src_install
+}
diff --git a/app-office/koffice-meta/ChangeLog b/app-office/koffice-meta/ChangeLog
index 751911849d04..fde6bd1ac68c 100644
--- a/app-office/koffice-meta/ChangeLog
+++ b/app-office/koffice-meta/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice-meta
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-meta/ChangeLog,v 1.85 2009/07/23 14:13:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-meta/ChangeLog,v 1.86 2009/08/12 10:02:28 scarabeus Exp $
+
+*koffice-meta-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +koffice-meta-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
koffice-meta-1.6.3_p20090204.ebuild:
diff --git a/app-office/koffice-meta/koffice-meta-2.0.2.ebuild b/app-office/koffice-meta/koffice-meta-2.0.2.ebuild
new file mode 100644
index 000000000000..1e1af3ef0590
--- /dev/null
+++ b/app-office/koffice-meta/koffice-meta-2.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-meta/koffice-meta-2.0.2.ebuild,v 1.1 2009/08/12 10:02:28 scarabeus Exp $
+
+EAPI=2
+
+DESCRIPTION="KOffice - merge this to pull in all KOffice-derived packages."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2"
+
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=app-office/karbon-${PV}:${SLOT}
+ >=app-office/kchart-${PV}:${SLOT}
+ >=app-office/koffice-data-${PV}:${SLOT}
+ >=app-office/koffice-libs-${PV}:${SLOT}
+ >=app-office/kplato-${PV}:${SLOT}
+ >=app-office/kpresenter-${PV}:${SLOT}
+ >=app-office/krita-${PV}:${SLOT}
+ >=app-office/kspread-${PV}:${SLOT}
+ >=app-office/kword-${PV}:${SLOT}
+ nls? ( >=app-office/koffice-l10n-${PV}:${SLOT} )
+"
diff --git a/app-office/kplato/ChangeLog b/app-office/kplato/ChangeLog
index 2679e2b0d38b..7da0b500d14a 100644
--- a/app-office/kplato/ChangeLog
+++ b/app-office/kplato/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kplato
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/ChangeLog,v 1.62 2009/07/23 14:08:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/ChangeLog,v 1.63 2009/08/12 10:04:18 scarabeus Exp $
+
+*kplato-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> +kplato-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
kplato-1.6.3_p20090204.ebuild:
diff --git a/app-office/kplato/kplato-2.0.2.ebuild b/app-office/kplato/kplato-2.0.2.ebuild
new file mode 100644
index 000000000000..cbe530c0bc17
--- /dev/null
+++ b/app-office/kplato/kplato-2.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/kplato-2.0.2.ebuild,v 1.1 2009/08/12 10:04:18 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KPlato is a project management application."
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+KMEXTRACTONLY="libs/"
+KMEXTRA="kdgantt/"
+
+KMLOADLIBS="koffice-libs"
diff --git a/app-office/kpresenter/ChangeLog b/app-office/kpresenter/ChangeLog
index 0557591f5637..e03e4a4e8631 100644
--- a/app-office/kpresenter/ChangeLog
+++ b/app-office/kpresenter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kpresenter
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kpresenter/ChangeLog,v 1.85 2009/07/23 14:09:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kpresenter/ChangeLog,v 1.86 2009/08/12 10:03:49 scarabeus Exp $
+
+*kpresenter-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +kpresenter-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
kpresenter-1.6.3_p20090204.ebuild:
diff --git a/app-office/kpresenter/kpresenter-2.0.2.ebuild b/app-office/kpresenter/kpresenter-2.0.2.ebuild
new file mode 100644
index 000000000000..cd604bd217e9
--- /dev/null
+++ b/app-office/kpresenter/kpresenter-2.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kpresenter/kpresenter-2.0.2.ebuild,v 1.1 2009/08/12 10:03:49 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice presentation program."
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.35.0"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libs/"
+KMEXTRA="filters/${KMMODULE}/"
+
+KMLOADLIBS="koffice-libs"
diff --git a/app-office/krita/ChangeLog b/app-office/krita/ChangeLog
index f1e13521dafa..c78851e21c2a 100644
--- a/app-office/krita/ChangeLog
+++ b/app-office/krita/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/krita
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/krita/ChangeLog,v 1.96 2009/07/23 14:09:57 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/krita/ChangeLog,v 1.97 2009/08/12 10:03:21 scarabeus Exp $
+
+*krita-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> +krita-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
krita-1.6.3_p20090204.ebuild:
diff --git a/app-office/krita/krita-2.0.2.ebuild b/app-office/krita/krita-2.0.2.ebuild
new file mode 100644
index 000000000000..b5d0c74360ad
--- /dev/null
+++ b/app-office/krita/krita-2.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/krita/krita-2.0.2.ebuild,v 1.1 2009/08/12 10:03:21 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KOffice image manipulation program."
+
+KEYWORDS="~amd64 ~x86"
+IUSE="+gmm +kdcraw +openexr +pdf +tiff"
+
+DEPEND="
+ >=app-office/koffice-libs-${PV}:${SLOT}[openexr=]
+ dev-cpp/eigen:2
+ >=kde-base/qimageblitz-0.0.4
+ >=media-gfx/exiv2-0.16
+ >=media-gfx/imagemagick-0.6.4.9.2[openexr=,png,tiff?]
+ gmm? ( sci-mathematics/gmm )
+ kdcraw? ( kde-base/libkdcraw )
+ opengl? ( media-libs/glew )
+ pdf? (
+ >=virtual/poppler-qt4-0.10.5
+ )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libs/"
+KMEXTRA="filters/${KMMODULE}/"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWITH_Eigen2=On
+ -DWITH_Exiv2=On
+ -DWITH_JPEG=On
+ $(cmake-utils_use_with openexr OpenEXR)
+ $(cmake-utils_use_with gmm GMM)
+ $(cmake-utils_use_with tiff TIFF)
+ $(cmake-utils_use_with kdcraw Kdcraw)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with opengl GLEW)"
+
+ kde4-meta_src_configure
+}
diff --git a/app-office/kspread/ChangeLog b/app-office/kspread/ChangeLog
index 7fccfd1b274f..b5ba0f6413b4 100644
--- a/app-office/kspread/ChangeLog
+++ b/app-office/kspread/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kspread
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.101 2009/07/23 14:10:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.102 2009/08/12 10:00:20 scarabeus Exp $
+
+*kspread-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +kspread-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
kspread-1.6.3_p20090204.ebuild:
diff --git a/app-office/kspread/kspread-2.0.2.ebuild b/app-office/kspread/kspread-2.0.2.ebuild
new file mode 100644
index 000000000000..9abc2bb80a71
--- /dev/null
+++ b/app-office/kspread/kspread-2.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/kspread-2.0.2.ebuild,v 1.1 2009/08/12 10:00:20 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice spreadsheet application."
+
+KEYWORDS="~amd64 ~x86"
+IUSE="+solver"
+
+DEPEND="dev-cpp/eigen:2
+ solver? ( sci-libs/gsl )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ kchart/
+ interfaces/
+ libs/
+ filters/
+ plugins/
+"
+KMEXTRA="filters/${KMMODULE}/"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DWITH_Eigen2=ON
+ $(cmake-utils_use_with solver GSL)"
+
+ kde4-meta_src_configure
+}
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 4f409cacda34..849c464f87de 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/kword
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.129 2009/07/23 14:12:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.130 2009/08/12 10:01:34 scarabeus Exp $
+
+*kword-2.0.2 (12 Aug 2009)
+
+ 12 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org> +kword-2.0.2.ebuild:
+ Version bump to 2.0.2.
23 Jul 2009; Raúl Porcel <armin76@gentoo.org>
kword-1.6.3_p20090204.ebuild:
diff --git a/app-office/kword/kword-2.0.2.ebuild b/app-office/kword/kword-2.0.2.ebuild
new file mode 100644
index 000000000000..93c8c58e4775
--- /dev/null
+++ b/app-office/kword/kword-2.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-2.0.2.ebuild,v 1.1 2009/08/12 10:01:34 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice word processor."
+
+KEYWORDS="~amd64 ~x86"
+IUSE="+wpd +wv2"
+
+DEPEND="
+ app-text/libwpd
+ app-text/wv2
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="filters/${KMMODULE}/"
+
+KMEXTRACTONLY="
+ filters/
+ kspread/
+ libs/
+ plugins/
+"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with wpd WPD)
+ $(cmake-utils_use_with wv2 WV2)"
+
+ kde4-meta_src_configure
+}