summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice-libs/koffice-libs-2.0.2.ebuild')
-rw-r--r--app-office/koffice-libs/koffice-libs-2.0.2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-office/koffice-libs/koffice-libs-2.0.2.ebuild b/app-office/koffice-libs/koffice-libs-2.0.2.ebuild
new file mode 100644
index 000000000000..a0f998505dcc
--- /dev/null
+++ b/app-office/koffice-libs/koffice-libs-2.0.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice-libs/koffice-libs-2.0.2.ebuild,v 1.1 2009/08/12 09:59:38 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="libs"
+OPENGL_REQUIRED="optional"
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Shared KOffice libraries."
+KEYWORDS="~amd64 ~x86"
+IUSE="+crypt +openexr"
+
+RDEPEND="
+ >=app-office/koffice-data-${PV}:${SLOT}
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ >=media-libs/lcms-1.15
+ >=x11-libs/qt-gui-4.5
+ crypt? ( app-crypt/qca:2 )
+ openexr? ( media-libs/openexr )
+ opengl? ( media-libs/mesa )
+"
+DEPEND="${RDEPEND}"
+# doc? ( app-doc/doxygen )"
+
+KMEXTRA="
+ doc/koffice/
+ doc/thesaurus/
+ filters/generic_wrapper/
+ filters/libkowmf/
+ filters/xsltfilter/
+ interfaces/
+ kounavail/
+ plugins/
+ tools/"
+# doc/api/"
+KMEXTRACTONLY="
+ doc/koffice.desktop"
+
+KMSAVELIBS="true"
+
+src_prepare() {
+ sed -i \
+ -e "s:QtCrypto/QtCrypto:QtCrypto:" \
+ libs/store/KoEncryptedStore.h || die
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with openexr OpenEXR)"
+ use crypt && mycmakeargs="${mycmakeargs}
+ -DQCA2_LIBRARIES=/usr/$(get_libdir)/qca2/libqca.so.2"
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ newdoc kounavail/README README.kounavail
+
+ kde4-meta_src_install
+}