summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/libhangul/libhangul-0.1.0.ebuild')
-rw-r--r--app-i18n/libhangul/libhangul-0.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-i18n/libhangul/libhangul-0.1.0.ebuild b/app-i18n/libhangul/libhangul-0.1.0.ebuild
new file mode 100644
index 000000000000..5ac2443ba582
--- /dev/null
+++ b/app-i18n/libhangul/libhangul-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libhangul/libhangul-0.1.0.ebuild,v 1.1 2011/11/28 14:06:24 naota Exp $
+
+EAPI="3"
+
+DESCRIPTION="libhangul is a generalized and portable library for processing hangul."
+HOMEPAGE="http://code.google.com/p/libhangul/"
+SRC_URI="http://libhangul.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls static-libs test"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )
+ dev-util/pkgconfig
+ test? ( dev-libs/check )"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}