summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libsecret/libsecret-0.15-r1.ebuild')
-rw-r--r--app-crypt/libsecret/libsecret-0.15-r1.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/app-crypt/libsecret/libsecret-0.15-r1.ebuild b/app-crypt/libsecret/libsecret-0.15-r1.ebuild
deleted file mode 100644
index 044d11d7d48a..000000000000
--- a/app-crypt/libsecret/libsecret-0.15-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/libsecret/libsecret-0.15-r1.ebuild,v 1.4 2014/03/01 22:30:47 mgorny Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python2_{6,7} )
-VALA_MIN_API_VERSION=0.18
-VALA_USE_DEPEND=vapigen
-
-inherit eutils gnome2 python-any-r1 vala virtualx
-
-DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
-HOMEPAGE="https://live.gnome.org/Libsecret"
-
-LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
-SLOT="0"
-IUSE="+crypt debug +introspection test vala"
-REQUIRED_USE="vala? ( introspection )"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.32.0:2
- crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
- introspection? ( >=dev-libs/gobject-introspection-1.29 )"
-RDEPEND="${COMMON_DEPEND}
- >=gnome-base/gnome-keyring-3"
-# Add ksecrets to RDEPEND when it's added to portage
-DEPEND="${COMMON_DEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- dev-util/gtk-doc-am
- >=dev-util/intltool-0.35.0
- sys-devel/gettext
- virtual/pkgconfig
- test? (
- dev-python/mock
- introspection? (
- ${PYTHON_DEPS}
- >=dev-libs/gjs-1.32
- dev-python/pygobject:3 )
- )
- vala? ( $(vala_depend) )"
-
-src_prepare() {
- # FIXME: disable failing test
- sed -e '/test_get_sync);/d' \
- -e '/test_get_async);/d' \
- -i libsecret/tests/test-service.c || die
-
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- DOCS="AUTHORS ChangeLog NEWS README"
- gnome2_src_configure \
- --enable-manpages \
- --disable-strict \
- --disable-coverage \
- --disable-static \
- $(use_enable crypt gcrypt) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_test() {
- Xemake check
-}