summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/joe/joe-2.9.8_pre1.ebuild26
-rw-r--r--app-editors/katoob/katoob-0.2.1.ebuild13
2 files changed, 7 insertions, 32 deletions
diff --git a/app-editors/joe/joe-2.9.8_pre1.ebuild b/app-editors/joe/joe-2.9.8_pre1.ebuild
index b03e76b4e95c..6745e8f94dcf 100644
--- a/app-editors/joe/joe-2.9.8_pre1.ebuild
+++ b/app-editors/joe/joe-2.9.8_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.9.8_pre1.ebuild,v 1.2 2002/11/12 17:50:29 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.9.8_pre1.ebuild,v 1.3 2002/11/30 02:41:02 vapier Exp $
MY_P=${P/_/-}
S=${WORKDIR}/${MY_P}
@@ -14,32 +14,12 @@ LICENSE="GPL-1"
DEPEND=">=sys-libs/ncurses-5.2-r2"
-#src_unpack() {
-#
-# unpack ${A}
-# cd ${S}
-# cp Makefile Makefile.orig
-# sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
-#
-#}
-
src_compile() {
-
- econf || die
+ econf
make || die
}
src_install() {
-# into /usr
-# dobin joe
-# doman joe.1
-# dolib joerc
-# for i in jmacs jstar jpico rjoe
-# do
-# dosym joe /usr/bin/$i
-# dosym joe.1.gz /usr/share/man/man1/$i.1.gz
-# dolib ${i}rc
-# done
- einstall || die
+ einstall
dodoc COPYING INFO LIST README TODO VERSION
}
diff --git a/app-editors/katoob/katoob-0.2.1.ebuild b/app-editors/katoob/katoob-0.2.1.ebuild
index 1854efcd03f7..944f36ef1dec 100644
--- a/app-editors/katoob/katoob-0.2.1.ebuild
+++ b/app-editors/katoob/katoob-0.2.1.ebuild
@@ -1,17 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/katoob/katoob-0.2.1.ebuild,v 1.2 2002/10/05 05:39:07 drobbins Exp $
-
-IUSE="nls"
+# $Header: /var/cvsroot/gentoo-x86/app-editors/katoob/katoob-0.2.1.ebuild,v 1.3 2002/11/30 02:42:46 vapier Exp $
DESCRIPTION="Small text editor based on the GTK+ library 2.0"
HOMEPAGE="http://www.arabeyes.org/project.php?proj=katoob"
SRC_URI="mirror://sourceforge/arabeyes/${P}.tar.gz"
-S="${WORKDIR}/${P}"
LICENSE="GPL-2"
KEYWORDS="x86"
SLOT="0"
+IUSE="nls"
DEPEND=">=x11-libs/gtk+-2
>=dev-util/pkgconfig-0.12"
@@ -19,15 +17,12 @@ RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
local myconf=""
-
use nls || myconf="--disable-nls"
-
- econf $myconf || die "Configuration failed"
+ econf ${myconf}
emake || die "Compilation failed"
}
src_install() {
- einstall || die "Installation failed"
-
+ einstall
dodoc ABOUT-NLS AUTHORS ChangeLog COPYING NEWS README THANKS TODO
}