summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/wget/Manifest4
-rw-r--r--net-misc/wget/files/digest-wget-1.9.11
-rw-r--r--net-misc/wget/wget-1.9.1.ebuild63
3 files changed, 66 insertions, 2 deletions
diff --git a/net-misc/wget/Manifest b/net-misc/wget/Manifest
index f2ee5f4dca28..a7f108d334ce 100644
--- a/net-misc/wget/Manifest
+++ b/net-misc/wget/Manifest
@@ -1,5 +1,5 @@
-MD5 926ffc12697b8834c544e1938c24165c ChangeLog 4249
-MD5 3358283c3c356f702f63b7b5edab3784 wget-1.9.1.ebuild 1513
+MD5 0a6150c50b45460d6f21ff6b65d9d2d2 ChangeLog 4362
+MD5 bfc23a7ae9649844e15b8d00578e24fc wget-1.9.1.ebuild 1510
MD5 f5aa635cf44fd78e4b7d92be4c6105ba wget-1.8.2-r2.ebuild 1490
MD5 11961cb8da0a697d08440e6f562a805a wget-1.8.2-r3.ebuild 1856
MD5 2b173c7a1e9e4a4a1aa7a6541b8c7316 wget-1.9-r1.ebuild 1587
diff --git a/net-misc/wget/files/digest-wget-1.9.1 b/net-misc/wget/files/digest-wget-1.9.1
new file mode 100644
index 000000000000..fc78fd386c38
--- /dev/null
+++ b/net-misc/wget/files/digest-wget-1.9.1
@@ -0,0 +1 @@
+MD5 e6051f1e1487ec0ebfdbda72bedc70ad wget-1.9.1.tar.gz 1322378
diff --git a/net-misc/wget/wget-1.9.1.ebuild b/net-misc/wget/wget-1.9.1.ebuild
new file mode 100644
index 000000000000..635007744ea0
--- /dev/null
+++ b/net-misc/wget/wget-1.9.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.9.1.ebuild,v 1.1 2003/11/14 17:11:47 mholzer Exp $
+
+inherit gnuconfig
+
+IUSE="ssl nls static debug socks5"
+
+NPVER=20031022
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
+SRC_URI="mirror://gnu/wget/${P}.tar.gz"
+#RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips ~amd64 ~ia64"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack ${P}.tar.gz
+# epatch ${DISTDIR}/${P}+ipvmisc.patch
+}
+
+src_compile() {
+ # Make wget use up-to-date configure scripts
+ gnuconfig_update
+
+ local myconf
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+
+ use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+
+ econf \
+ --sysconfdir=/etc/wget \
+ `use_enable nls` \
+ `use_enable debug` \
+ `use_with socks5 socks` \
+ ${myconf} || die
+
+ if use static; then
+ emake LDFLAGS="--static" || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ if use build; then
+ insinto /usr
+ dobin ${S}/src/wget
+ return
+ fi
+ make prefix=${D}/usr sysconfdir=${D}/etc/wget \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc AUTHORS COPYING ChangeLog MACHINES MAILING-LIST NEWS README TODO
+ dodoc doc/sample.wgetrc
+}