summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-05-27 00:39:14 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-05-27 00:39:14 +0000
commit5f40e90aaff1f85523403c69f689243a687115f2 (patch)
treecc27fcbe3e69bcd367ef747049770b24eb74dd88 /x11-wm
parentnew snapshot (diff)
downloadhistorical-5f40e90aaff1f85523403c69f689243a687115f2.tar.gz
historical-5f40e90aaff1f85523403c69f689243a687115f2.tar.bz2
historical-5f40e90aaff1f85523403c69f689243a687115f2.zip
uploading broken stuff. bad snapshot
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/sawfish/ChangeLog7
-rw-r--r--x11-wm/sawfish/files/digest-sawfish-200205241
-rw-r--r--x11-wm/sawfish/sawfish-20020524.ebuild59
3 files changed, 66 insertions, 1 deletions
diff --git a/x11-wm/sawfish/ChangeLog b/x11-wm/sawfish/ChangeLog
index 80f545e23cdd..21297189e6a0 100644
--- a/x11-wm/sawfish/ChangeLog
+++ b/x11-wm/sawfish/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/sawfish
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.7 2002/05/22 22:45:18 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/ChangeLog,v 1.8 2002/05/27 00:39:14 spider Exp $
+
+*sawfish-20020524 (27 May 2002)
+ 27 May 2002; Spider <spider@gentoo.org> sawfish-20020524.ebuild :
+ new snapshot. still doesn't work
+
*sawfish-20020419 (22 May 2002)
22 May 2002; Spider <spider@gentoo.org> sawfish-20020419.ebuild :
diff --git a/x11-wm/sawfish/files/digest-sawfish-20020524 b/x11-wm/sawfish/files/digest-sawfish-20020524
new file mode 100644
index 000000000000..648420ffdbc1
--- /dev/null
+++ b/x11-wm/sawfish/files/digest-sawfish-20020524
@@ -0,0 +1 @@
+MD5 e6b01c0c7b37e2ecfc27c8b544258d98 sawfish-2002-05-24.tar.bz2 1116006
diff --git a/x11-wm/sawfish/sawfish-20020524.ebuild b/x11-wm/sawfish/sawfish-20020524.ebuild
new file mode 100644
index 000000000000..60a6620e721f
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-20020524.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/sawfish/sawfish-20020524.ebuild,v 1.1 2002/05/27 00:39:14 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+MY_P=${PN}-2002-05-24
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${MY_P}.tar.bz2"
+HOMEPAGE="http://sawmill.sourceforge.net/"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=x11-libs/rep-gtk-20020419
+ >=dev-libs/librep-20020419
+ >=media-libs/imlib-1.9.10-r1
+ esd? ( >=media-sound/esound-0.2.22 )
+ readline? ( >=sys-libs/readline-4.1 )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --with-gnome-prefix=/usr"
+ myconf="${myconf} --enable-gnome-widgets "
+ myconf="${myconf} --enable-capplet"
+ myconf="${myconf} --enable-themer"
+
+ use esd && myconf="${myconf} --with-esd" ||myconf="${myconf} --without-esd"
+ use readline && myconf="${myconf} --with-readline" || myconf="${myconf} --without-readline"
+ use nls || myconf="${myconf} --disable-linguas"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --libexecdir=/usr/lib \
+ --with-audiofile ${myconf} || die
+ mkdir ${S}/src/.libs
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog DOC FAQ NEWS README THANKS TODO
+
+ # Add to Gnome CC's Window Manager list
+ insinto /usr/share/gnome/wm-properties
+ doins ${FILESDIR}/Sawfish.desktop
+
+}
+
+
+